Cannot install Atomik in V9.1.2

I have a relatively simple site. I upgraded from the most recent
V8 and now at v9.1.2. When I upgraded Boards had no templates. So I installed a brand new concrete (for the same website). Still no Board templates. So I’ve tried installing Atomik documentation. I get the following error. I saw somewhere that this was supposed too have been a fixed issue, but apparently not. I have no idea what to do. Please help!
BTW: Tried with php 7.4 and 8.03

I just discovered something else. This link discusses Boards.

@baxterdmutt How did you upgrade, the Dashboard Or one of the ways listed in this document? How to Upgrade Concrete CMS

Thank you,

Every way possible. I backed everything up. (directories and database). Then I tried through the dashboard. It was a mess, so I restored everything, tried it through the cli. Same mess. Then I tried the replace method where you download the new version and do it that way. Same mess. Not one of them would let me install the Atomik Documentation. The results each time we’re identical.

I even tried php 8 or 7.4. The error I posted was from php8. Trying with php 7.4 gave me a null error and I’m sorry I deleted that screenshot. I think I posted it on GitHub. I’m not trying again because each time I do it puts a bunch of empty page data in the db and images in the files.

Hi @baxterdmutt - can you describe your environment a bit? Is this a linux environment? To troubleshoot, I just want to make sure we are aware of anything that might be unusual about the environment so we can help you troubleshoot. Thx.