Cannot upload files anymore

I’ve set up a new site for a client. During development I’ve also uploaded many files.

Suddenly I get the following error message when I try to upload a new file via the file manager as well as importing the file programmatically:

Exception Occurred: …/concrete/src/File/Image/Svg/Sanitizer.php:36 Class ‘enshrined\svgSanitize\Sanitizer’ not found (0)

I have already tried a lot to solve this, e.g. swap the core, re-install, deactivate my built theme and addons … error remains.

I appreciate any suggestions/help on this - thanks a lot!

Is this error thrown when uploading svg files only?

It might help if you post your environment info, especially your PHP Loaded Functions.

No, for every file types

Another tool throws now the same error message:


    public function __construct(Filesystem $filesystem)
            $this->filesystem = $filesystem;
            $this->enshrinedSvgSanitizer = new EnshrinedSvgSanitizer();

Class 'enshrined\svgSanitize\Sanitizer' not found``

What exactly else could post so your have a better picture?

Thanks a lot!!

Maybe you have hit your server’s inode limit preventing further files from being uploaded?
Ask your hosting tech guys if that is the case, you will often find a error logged in the servers log files.

If you have cPanel access you can check your inodes by looking on the right hand side panel for ‘File Usage’, you will see
‘Files Used’ / ‘Limit Allowed’, if you see ∞ in the ‘Limit Allowed’ section that means ‘Unlimited’

Thanks. I have downloaded the installation and db and the same error occurs on my local machine …

Sorry, I cannot hep any further, I have run out of ideas!

Sometimes the Doctrine proxy classes get messed up. You can try going to dashboard/system/environment/entities and ‘Refresh Entities’.

I have it working now but when I try to send you a PM it does not go?
Try sending me another PM and I will try to reply to it.

Thanks for your support - but also didn’t change it

Just sent another pm …

I have replied just now to your email address …

The classes you are having issues with are at /concrete/vendor/enshrined/svg-sanitize/src
So you can check you actually have those files in in your source.

I am glad that that new file I sent you has fixed your immediate problem with uploading files.
The error you reported was a bit of a red herring though…
I have found some other minor errors and will send you the updated files soon.

1 Like

All the remaining errors being reported by the browser console were due to file path errors with the files of your custom theme.
I have sent you a new zipped up theme file now to your own email address, these new files have cleared up all the browser console errors I was seeing so hopefully you should be ‘Good To Go’