Disabled in Edit Mode - Sometimes appears when not in edit mode

Hi, when disabling block output in the view in Edit mode, the message can sometimes appear after publishing changes.
Clearing the cache normally fixes it.
Is there a way to avoid that happening?

Check the cache flags in the block controller. There is a flag about caching output on post or save that needs to be false.

If it’s not your block, you can override the cache flags using the Advanced menu (in the same list as ‘Edit Block’ and ‘Design & Block Template’

On older core versions (pre 8.5.something) there was a bug in detecting edit mode that could lead to blocks with an edit mode placeholder getting confused.

1 Like

Great thank you!
It was indeed set to true, so I have changed that now.