Error Connecting to Project

I have a new install of v9.1.1. I created a new project and enter my ID and Secret Key like normal on any other install. Upon attempting to connect, I get a new page displaying the following error.

use Concrete\Core\Marketplace\Marketplace;
defined('C5_EXECUTE') or die("Access Denied.");
 * @var $permissions \Concrete\Core\Permission\Checker
 * @var $marketplace Marketplace
if ($permissions->canInstallPackages()) { ?>
    <form method="post" class="ccm-dashboard-content-form" action="<?=$view->action('do_connect')?>">
    if ($marketplace->hasConnectionError()) { ?>
        <h4><?=t('Marketplace Error')?></h4>
        if ($marketplace->getConnectionError() == Marketplace::E_INVALID_BASE_URL) { ?>
                <div class="alert alert-danger">
                <h5><?=t('Error: Invalid Base URL')?></h5>
                <p style="font-size: 1.2rem"><?=t("The URL of this site has not been registered as a valid location in the Concrete marketplace. Please sign in to the project page for this site and add the following URL as a site instance:")?></p>
                    <input readonly class="form-control" onclick="" value="<?=$marketplace->getSiteURL()?>">
        } else if ($marketplace->getConnectionError() == Marketplace::E_UNRECOGNIZED_SITE_TOKEN) { ?>
                <div class="alert alert-danger">


  1. “Undefined variable $permissions”

First, I need to figure out why my session keeps getting disrupted in my browser. That has a lot to do with it. I click on something in the dashboard and I’m brought to the Concrete login screen again. Currently using Firefox but will test with another browser and retry connecting to my project provided I do not keep getting logged out.

Same behavior with Chrome browser. I also get the following message because my site uses an SSL certificate and is accessed via https but the info saved after project creation doesn’t seem to save whether it’s HTTPS or HTTP.

Error: Invalid Base URL

The URL of this site has not been registered as a valid location in the Concrete marketplace. Please sign in to the project page for this site and add the following URL as a site instance:

what version of php are you on? That undefined variable looks like a php8 issue…

Php 8.1 is currently installed.

@jmonroe If you can, revert to php7.4 and see if that alleviates the issue. If it does, this should be made issue on github. Issues · concretecms/concretecms · GitHub

I was on 7.4 and having the issue so I upgraded to 8.1. I still have to resolve the issue of the sessions immediately logging me out after clicking on a link in the dashboard. I have to keep logging in after every click I do. I have tried on my desktop (linux box), my laptop (windows), my Android Phone all with different browsers on each device but having the same result. I am going to reinstall concrete 9.1 using composer versus zip and see if I have a different outcome. I will update this post with results.

Still the same results after installing v9 via Composer. Very strange. Will look more on the server side and see if I can figure anything out that could be wrong.

This could be due to a user_agent_ip_mismatch.
Take a look in the concrete/config/concrete.php file starting line number 1256 and try setting those value to ‘false’
If that fixes it for you, you will need to create an over-ride of the concrete.php file in the application/config folder with your modded code and undo the changes to the original concrete.php file.

1 Like

The other issue I am having is my site was installed at I have forced accessing http :// to https. If I type in mysite . com, it brings me to, however, upon login, it brings me to mysite . com (unsecured). That is a problem also that is affecting connecting to the community because I am installing using SSL and creating a project I enter https ://mysite . com. Once the project is created and I hover the mouse over the project name, the link does show https ://mysite . com. No matter what I do, it reverts to http after logging in to the site.

Hi @jmonroe - do you want to make a new thread for this please? Just want to make sure this thread is dealing with a specific issue. Thanks!

No, because it’s related. The project gets created as https and I can access the site via https but once I login to the dashboard, it reverts to http and then the extend concrete section states the link is invalid and the site never links to the project.

@jmonroe What are your Urls and Redirection set to? You may need to set the canonical URL. or check out what code exists in your .htaccess file and see what’s going on.


Did you get this answered?

I’ll report back and let you know.

@jessicadunbar I am not sure why you tagged me in this post.

My urls and canoncial url match exactly. The only way the site works and connects to my project created in my Concrete Profile is by using http only. I reinstalled using composer and set the canonical as http :// mysite .com/ and no alternative. I create the project using the same url. Connections successful and site works. For some odd reason, if I try to install Concrete using https, the site will install and I can access it, but as soon as I login, the dashboard is http and tells me unsecure site and the project has the wrong url, etc.

I am not using this site for anything related to purchases or anything needing ssl so for now, it will be okay until I figure it out.