FullCalendar no longer populating after v9 Upgrade


Our Calendar has stopped working :frowning: To test it I have created a new blank calendar and i’m still getting the same error. When following the link to the events feed at the url domainurl/calendar/get_events/1234, I get:

An exception occurred while executing 'SELECT vo.versionOccurrenceID FROM CalendarEventVersionOccurrences vo INNER JOIN CalendarEventOccurrences eo ON vo.occurrenceID = eo.occurrenceID INNER JOIN CalendarEventVersions ve ON vo.eventVersionID = ve.eventVersionID INNER JOIN CalendarEvents e ON ve.eventID = e.eventID LEFT JOIN CalendarEventSearchIndexAttributes ea ON e.eventID = ea.eventID WHERE (e.caID = ?) AND (()) AND (eo.endTime >= ?) AND (eo.startTime <= ?) AND (ve.evIsApproved = 1) ORDER BY eo.startTime, ve.evName ASC' with params [3, false, false]: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ')) AND (eo.endTime >= '') AND (eo.startTime <= '') AND (ve.evIsApproved = 1) ...' at line 1

If I turn off Topic filtering I just get an empty array returned, at the above url.

But when I turn it back on it errors again, same as above?

Any help very gratefully received :slight_smile:

Ok, looking at the source code, there is a line that goes:

<link href="https://somedomain/ccm/calendar/feed/1" rel="alternate" type="application/rss+xml">

That url provides this error:

Controller "Concrete\Controller\CalendarFeed::view()" requires that you provide a value for the "$identifier" argument. Either the argument is nullable and no null value has been provided, no default value has been provided or because there is a non optional argument after this one.


Can you let me know what version of PHP and Concrete you are running? Thanks.

What version of PHP are you running?

Hi Evan, thanks for taking the time to reply, sorry for the late response. I am using

PHP Version


However I decided it was related to the upgrade and reupgraded from the backup and reinstalled the core (not using the updates folder) and it worked, so not sure what happened.

Hi Jess, thanks for taking the time to reply, sorry for the late response. Please see the above reply to Evan.