My website (ConcreteCMS 9.1.2) no longer works on Plesk host running MariaDB 10.6

Website is up and running with legacy MariaDB 10.4. No luck with 10.6.

There are now 3 DBs on my Plesk host:

From Admin this morning: I’ve pointed your website to the legacy database and your website is up now.

MariaDB 10.6

MariaDB 10.4 assigned to

MariaDB 10.4

Last night I tried a clean install of CMS 9.1.3 with DB 10.4 and got most of the way through the installation… so got through the Localhost blockage… then I got a large page of errors and gave up.

I then reinstalled my archived website backup and DB which was created under CMS 9.1.2 and MariaDB 10.4 and couldn’t get my website up and running. Then I asked Admin to get my website up and running again under DB 10.4… done this morning.

My plan now is to capture all my web pages, images and text even though I have most of the stuff on my computer… for a future website reconstruction… my current website has had a few tweaks since my Sept 2022 archive which I want to capture.

If it were a known MariaDB version problem, I think one of the more knowledgeable users would have chimed in by now. For instance, @JohntheFish didn’t think it was a dB version problem, so that still leads me to believe it’s just a dB connector configuration problem.

Has the host admin attempted to set the configuration? You can change the password after they get the connector to work.


  • Server:
  • Database: gman881
  • Username: gman882 (or gman883)
  • Password: ********


  • Server:
  • Database: gman880
  • Username: gman880
  • Password: ********

Doesn’t Work?

  • Server: localhost
  • Database: 27777012_
  • Username: gman880
  • Password: ********


DB gman881 is a copy of gman880 and me playing about.

DB gman880 is the one that is working at present using MariaDB 10.4.
Shown as Host: (MariaDB)
Admin says: I’ve pointed your website to the legacy database and your website is up now.

DB 27777012_ doesn’t work and is MariaDB 10.6.
Shown as Host: localhost:3306 (MariaDB)

I will ask admin to check and set the connector config for MariaDB 10.6

I have been thinking of doing a rebuild of my website using ConcreteCMS 9.2.
While my existing site is up I have made fresh backups.
On my computer for each of my website pages I have saved a PDF printout, an HTML copy and a copy of every image.
If I go ahead with the rebuild I will first get the host admin to clear all history, caches and return all settings to default… ie a blank canvas. There is one config exception: I had to get admin to previously change: open_basedir restriction to none - I can’t remember why that was.

My webhost has just emailed me after I suggested that there was a DB connector problem based on the help from this forum. Many thanks to everyone for your help.

Great news, I’ve reverted back your database to the new version, and I modified your database connection string and that worked.

Sweat over :smile:


Saga is not over yet.
My website displays with MariaDB10.6 but I can’t log in to edit.
Removed all files and the database from the web host.
Attempted to install ConcreteCMS 9.2 with a new DB.
Fails part way through the install:

Handling “Concrete\Core\User\Group\Command\AddGroupCommand” failed: SessionHandler::read(): open(/var/lib/php/session/sess_7j1m3e0k2dutdcfguf1ke0t4l6, O_RDWR) failed: No such file or directory (2).

#0 /var/www/vhosts/ Symfony\Component\Messenger\Middleware\HandleMessageMiddleware->handle() #1 /var/www/vhosts/ Symfony\Component\Messenger\Middleware\SendMessageMiddleware->handle() #2 /var/www/vhosts/ Symfony\Component\Messenger\Middleware\FailedMessageProcessingMiddleware->handle() #3 /var/www/vhosts/ Symfony\Component\Messenger\Middleware\DispatchAfterCurrentBusMiddleware->handle() #4 /var/www/vhosts/ Symfony\Component\Messenger\Middleware\RejectRedeliveredMessageMiddleware->handle() #5 /var/www/vhosts/