[9.0.1] theme skin customizations

Hey there - new to concrete, bit confused by the theme customization.
Able to edits to the presets in either the default Elemental or Atomik theme in the Theme Customizer, but can only save them to the page/site. If I close and return to the Theme Cutomizer, I have to choose one of the presets again and all customizations are lost.
I noted in this video of v9 the theme customizer offers a ‘Create New’ button instead of a ‘Save Styles’ button that creates a new preset - which seems to be what I want.

Is this a feature still in the works or am I missing something?

1 Like

Anyone know about this?

Go to dashboard/pages/themes
Click the gear icon on the theme you want to customize and select ‘Customize’
Click the Pencil icon (top left)
Click the Preset you want to edit
At the bottom right of the page click ‘Create New’
Give your new skin a name and click ‘Create’

Thanks @ConcreteOwl, I think that’s where I’m having the issue, no Create New button appears. Just a Save Styles button. Tried on both Atomik and Elemental themes.

Can you post a screenshot of your list of available presets.

I can confirm this. “Create New” in the customizer is not available.

Also, in the customizer, when you try to add custom CSS, there’s no save button.

We added a HTML block and use our CSS from there, > very rocky approach.

For me (on two sites) when I go to the skin customizer and click ‘Default Skin’ I get the ‘Create New’ link, so I create a new skin based on the ‘Default Skin’ and give it a name of ‘My Skin’, when the page finishes loading I go back to skin customizer and click on ‘My Skin’ and I can then see the ‘Save Edits’ link.

Aha I’ve discovered the issue: using Elemental, I don’t get the option to create a preset, but if I use Atomik, and select Default preset, I do get an option to Create New.

So seems to be an issue with Elemental only. Unfortunately Atomik has no built-in typographic settings so I had been using Elemental, but it makes a bit more sense now. Thanks

I am having the same issue, using the “Neat” theme". The only Preset I have is “Black”, and there is no option “Create New”. I have two website that I updated

Website 1 from 8.5.6. to 9.0.1.
Website 2 from 8.5.7. to 9.0.1.

Both websites, when I got to customize the design of the theme, the only option that appears is “Save Styles”, and “Create New” Button is nowhere to be found, so even if my style is saved, it forces me to pick a preset, which is the default colors/text sizes/fonts etc, reversing the changes I made.

Does anyone know if this is a Concrete 9.0.1 bug that needs fixed? and If so, is there currently a fix being worked on?

Just, I am trying to complete a website for a client at this time, and we’d like to easily/freely make changes to colors and design.

Upgrade from v8 is not yet officially supported.
Also, check the marketplace to confirm addon/theme compatibility with v9.

1 Like

Thank you very much for your help! It’s been since about August-September 2021 since we last visited the Marketplace. That is good reminder!

We ended up doing a Website backup restore, and both our websites are on 8.5.7. for now until the Version 9 kinks are worked out.