9.0.2 Lost main editing tool bar

Have started playing with 9.0.2 and really liked the look of the new Atomik theme.

I installed with a blank elemental site and activated the Atomik theme. The first thing I wanted to do was edit the “Empty Sitewide Navigation Area” by adding a “Top Navigation Bar” block, using default settings and just a text branding option.

Then noticed the main editing toolbar had disappeared and could not longer get to the dashboard.

Was still in edit mode so clicked on another area to add a block, which brought the editing toolbar back so I clicked “Exit Edit Mode” and published the changes.

This again removed the main editing toolbar but I was no longer in edit mode so could not do anything.

The only way to get back to the dashboard is to log out and log back in but I’m still stuck because when visiting the home page the main editing toolbar is still not present.

Going to the flat view of the site, deleting the new version and making the initial verion “live” didn’t seem to work either.

Can obviously just re-install the cms and try again but not a good start to my v9 experience.

Does this happen in 9.0.1 and should I use that older one?


Cleared the decks and did a Full Site install of Atomik to check how it’s “Top Navigation Bar” worked.

Noticed that it had all options checked.

The default setting for a new “Top Navigation Bar” has only two options checked, “Show pages in the navigation bar” & “Enable sticky navigation bar on scroll if theme supports it”.

It seems that unchecking “Enable transparent functionality if the theme supports it” while having “Enable sticky navigation bar on scroll if theme supports it” checked causes the missing editing toolbar problem.

This is confirmed by entering “problem mode” and using browser developer mode to remove the “Top Navigation Bar” from the dom to reveal the editing toolbar underneath.

I suggest making the option defaults for a new “Top Navigation Bar” have all options enabled or patch how sticky navigation bars work in editing mode.

Now going into sass learning mode so I can style things.


There is a discussion on this very issue on GitHub at https://github.com/concrete5/concrete5/issues/10275