Access denied after updating from 8.5.9 to 9.1.2 and other issues

Dear Concrete forum,

After updating from 8.5.9 to 9.1.2 using the manual upgrade method by copying the newest concrete folder to the updates folder and updating the website on the dashboard. After hitting update, everything works properly, except after updating one of my blocks. It comes up with the following message:


This only happens when I’m logged in as admin, and this happens upon every new page load. To test wether this also happens with other users, I’ve created a new account as non-admin. I logged in, no problems. I edited the user’s group to belong to the administrator group, logged in, same error. So I logout as user, log back in as admin, delete the user via the dashboard → members, and Concrete is screaming at me with the following error message when trying to delete said user (he’s still in administrator group)

I go back to the dashboard and go to the members page again, only to see that the user is still present, but he doesn’t belong to the administrator group anymore without any action of my own other than trying to delete the user.

What do I need to do to fix it?

Kind regards!


@PATRICKKASIE What block is causing the issue? Is it an add-on? lets check and make sure it’s compatible.

The second admin issue, are you able to open a separate thread and Paste your Concrete CMS site’s configuration under Dashboard > System & Settings > Environment > Environment Information

@jessicadunbar I’m not sure I fully understand your reply, so here goes what I can tell you:

Replying to your first paragraph: after having edited the native Concrete “Image block” (replacing an image), the error Access Denied happens after every page load. That means browsing the website while logged in as a user with admin permissions. It’s been 4 years since an image block has been last touched upon, and it seems it’s part of an override in the application folder. Check the following thread:

Second paragraph: Thread for Concrete CMS site’s configuration 9.1.2

Edit: I’ve tested this on a different server, upgrading from 8.5.9 to 9.1.2, adding a content block did the same thing


So looking at that error, it looks like there’s a foreign key constraint on the user you’re trying to delete and the “GroupSignupNotifications” and “GroupSignups” - these look like custom tables, I don’t believe they are core tables.

My guess, if this is custom functionality, is that it needed to do some more work to remove old associations when a user is deleted.

Dear @EvanCooper ,

The tables appear to be part of V9 and not V8. This might explain why there’s a problem updating the database if it wasn’t part of one version to another. Both websites are not the one mentioned above

Dear @jessicadunbar ,

I haven’t received feedback, so I assumed my problem would be solved after updating the website at hand from 9.1.2 to 9.1.3 using the remote_updater. This resulted in the following behavior of that site:
I can no longer visit the homepage when I’m being refered from any page other than the home page. This results in a 500 error with the following log:

I am not logged in to this website as this referal is happening. When logging in and browsing the website, I get the same error as my initial problem, but with a different version.

When I’m logged in and I go to the homepage, the dashboard banner is not present. It is present on every other page though.
The home page itself is broken with missing blocks in general.
The header is working.
The footer is missing.

The following is also true when I’m not logged in:
The home page itself is broken with missing blocks in general.
The header is working.
The footer is missing.

Edit: if it’d be possible, I’d like to send you a private message with the link to the affected website.

Dear forum,

I have yet to receive a solution to this problem These problems. Consider this a bump.

Kind regards,