Admin privileges not allowing site updates

Since upgrading from 8.5.7 to 8.5.12 I have experienced problems with some blocks not saving updates. I get the following error message ‘This is a members’ area, you need a user name and password’

This is getting really annoying. I have disabled some extensions but that hasn’t resolved the problem.

Grateful for any suggestions of help to resolve this problem.

Thanks, Doug

I just searched the codebase for the exact phrase ‘you need a user name and password’, and that didn’t come up. It also doesn’t really sound like a message from Concrete’s code either.

So I’d be suggesting it’s coming from something like a specific add-on, or maybe even the theme itself. A screenshot might also help as someone might recognise the message.

Error message
Attached is the message.
The theme in use is Neat v0.9.2
Hope this helps
Thank, Doug

As I was unable to continue with the current site after upgrading to 8.5.12 due to thge issues above I bit the bullet, deleted everything and did a complete fresh install of 9.1.3 Atomik with data. So far so good.
However, after adding a few pages and starting to populate the pages I am experiencing a similar problem.

Thanks for any help

That problem is a bit different - that’s caused by the server blocking things automatically.

It’s normally blocked by ‘Mod Security’, which helps to automatically stop scripts, spam and other stuff from being sent to the server. Most of the time it just works quietly in the background, but occasionally it can block things like saving blocks due to the kind of content you put in.

So for this one you’ll need to:

  • trigger this error again, take note of the time
  • contact your host, and ask them to ‘whitelist any Mod Security rules triggered around the time X’, for your domain

Sometimes you can turn on and off Mod Security yourself via cPanel too. You want to keep it on, but turning it off for a short period to get some content into a site is ok.

Thanks Mesuva for your response. Pinning it down more I have narrowed it down to pasting in text or making chnages to text using the Rich text Editor. If i type in and don’t try to format the text it mostly seems to work.
I had already referred it back to the host via support ticket as i suspected it was something on the server configuration causing the problem. I have also forwarded your response to them. Now waiting for a reply.