After updating 8.5.15 to 9.3.1

I recently updated from 8.5.15 to 9.3.1 the update went Ok but I do have a couple of issues.

  1. When the welcome page loads it tells me: It can’t connect to the new market place as this version does not support it and I should update to 9.3.1 but I am on 9.3.1

  2. When I tried to set canonical URLs I lost access to the dashboard. I eventually got access back by editing concrete.php and site.php so every thing is back to how it was before I tried to setup pretty URLs. I am only trying to do this as the site health check says I should set these up!

From what I read here I suspect my .htaccess file is not correct (it was last modified in 2018) but I am a bit out of my depth here!
I have been running concrete5 for my own website since 2018 but my technical understand is still basic, so don’t get to technical!

Thanks for any help.

You don’t have to have pretty URLs. If you are happy with the URLs you have, then ignore that suggestion.

I suspect the notice you are seeing on the welcome page is a vestige of an older version. Does it look like this:

If so, the “featured addon” and “featured theme” desktop tile/call to action things used to pull in content from the old marketplace, but they were removed in version 9. But if you have upgraded from version 8, those tiles are still installed and the content you are seeing is messaging to version 8 users.

In 9.3.2 we will just make them link to themes and add-ons in the marketplace or something less confusing. You can just ignore those.

Thanks for you reply, much appreciated.

  1. The site seems to be working fine, so I will ignore the pretty URLs suggestion!

  2. Yes that is exactly the notice I am seeing, great I will ignore them and wait for 9.3.2

Thanks agin for your help.

9.3.2 has just been released: GitHub - concretecms/concretecms at 9.3.2

Great, thanks for letting me know.

I just tried to update to 9.3.2 from the dashboard but when I try to download the update it says it cannot find the class zip archive?

It may be you need to enable a php extension in your host’s cPanel. That would normally be a pre-install requirement, but could have become lost during re-hosting or a long chain of updates.

If not the above, in your site dashboard, enabling the full debug details and trace may provide more information.

I’ll look in to that, if not I could try uploading the 9.3.2 update manually, I have done that before, although sometimes there are files that my FTP app will not upload, I guess I could upload it via cPanel.

Thanks for your help.

When doing a manual update, I usually get the zip directly in cPanel (much quicker than uploading unzipped files), extract somewhere outside of the web root, then rename the /concrete dir of the site and move in the /concrete dir of the new version.

(backup everything first)

Thanks for that info, it’s really appreciated. I will try and sort this out later.

Thanks again

I have now successfully updated to 9.3.2 but I still get that same old welcome page and when I click on the learn more it still takes me to the same page telling me update to V9.

Anyway I will just ignore it as the site works fine.

Yeah, it looks like those planned changes didn’t make it into that release (my fault for promising that!). I’ve made an issue here to see if it can get into the next release.

As a workaround, you can just remove the blocks from that view. There’s a “customize” button on that page that allows you to edit the order of the blocks and what shows up at all.

Thanks for telling me, as long as I know it wasn’t something wrong with my update install.

1 Like