An unexpected error occurred. Module 'PDO' already loaded

I have reached out to webhostinghub about this issue, as I occasionally will get random errors at the bottom of this website (removed because I was flagged). They claim that this is a concrete5 issue. I think they are incorrect (as I have had issues with another website that I built around the same time with them, and they have had to help remove error issues before for both sites).

I built this website in 2015 and haven’t needed to update it in years. So, I don’t understand why this kind of stuff happens (aside from, possibly, webhostinghub merging with inmotionhosting and shifting things around).

Does anyone know how to fix this? It has rendered concrete5 useless, apparently.

I have not seen your error, so this is just me being hypothetical.

It could be a secondary error.

A primary error occurs and a consequence is that the CMS tries to run the CMS within itself.

Akin to (but maybe not the same as) when an error is reported, but there is an error (maybe the same error) in the error reporting.

Do you have any custom functionality or scraps of third party HTML pasted into HTML blocks?

If you enable full in-page debug in the dashboard, you may get a full trace for the in-page message.

1 Like

I was able to pull up the debug panel, and it’s huge. I tried to copy/paste it here, but I got a warning about sharing links to “this host.” Huh.

Do you know what I should be looking for, or is there a certain section I should try to share to get help, here?

In the debug panel, there is a ‘Copy’ button that copies a JSON trace to your clipboard. Try pasting that into here.

So, I can’t find the copy button of which you speak, but the debug panel shows up on the website itself, now. I put it (the website) in a prior message, and apparently, I got flagged for sharing a screen shot . . . so . . . this is bizarre all around.

My internet keeps going out on me today, too, so I’m in the pit of technological despair.

I guess I’m not allowed to share any links, which makes this incredibly difficult.

Your site is running concrete which is quite an old version requiring the server to be running on an old PHP version.
2 things to check, has the PHP version been upgraded to a newer version and has the safe mode been turned off?
If this is a safe mode problem you can add a line to the htaccess file like this

php_admin_flag safe_mode On

If you have access to the server cPanel I could take a look for you if that would be of help to you.

I doubt the PHP has been upgraded to a newer version, unless it was automatically done. I have not upgraded it. I do have cPanel access. How does one check these things? I can dig into stuff on Notepad++ from cPanel (edited because my brain went on autopilot while I typed this), but I just don’t have a clue as to what I am doing (obviously).

To check your PHP version in cPanel, look in the software section, choose ‘Select PHP Version’ and see what it reports as selected.

@JennyDillBrown It’s because you just registered so the spam filters have a hard time determining if you are trying to spam the forums or not. Clearly you are not so I’ve adjusted your user’s trust level. Please try again and let me know if you continue to have issues posting.

1 Like

Try setting the PHP Version to 5.6.
Tick the box next to your domain name, select 5.6 from the Version selector box and ‘Apply’

1 Like

Oh my gosh. That did it. I feel kind of dumb, but thank you so much for holding my hand through this. Haha! I really appreciate it. All of you!

Your very welcome, I am pleased we got there in the end.
However, your hosting company should have seen that, instead they look to blame the cms.
Lets call it incompetence!

Yeah. I’ve been somewhat frustrated with webhostinghub for a few years. I have another website that I built in 2013 that was hosted with them as well, and I’ve had a lot of headaches with them over the years.

If you decide to move to a better hosting company and need assistance with the migration process, send me a private message.