Block edit hangs on save

When saving a block edit, the page hangs as can be seen in the attached pic. The progress bar almost makes it to the far right and stops. The edit is not saved.

Another odd thing is the ‘Dashboard - Change Site-wide settings’ tree is blank. I’m unsure if the two are related.

Here’s the environment:

server OS: debian 11
apache2 version: 2.4.56
php version: 7.4.33
mariadb version: 10.5.19
c5 version: 8.5.12
c5 theme: Palette
client OS: win10 & win11
client browser version: firefox 112.0.2 & edge 112.0.1722.64

Approximately a month ago I was able to save block edits normally. Since then the debian server has received normal updates and the client browser versions been updated as new version became available. Thinking it was a browser issue, I also tried brave, pale moon and waterfox without success.

I switched the site to the elemental theme and the issue persists.

The apache logs do not contain anything related to the browser hanging - no errors.

Does anyone have a suggestion on how I could diagnose and fix the problem? I’d appreciate any help - I’m stumped.


Do any of your blocks include scripting language? If so, it may interfere with the editor. I’ve used an add-on created by @mesuva in the past to work around that problem.

Thanks for the suggestion. No - none of my blocks have any scripting.

I’ll check out the add-in just in case.

I’m not sure if CSS could cause the page refresh to hang, but it might be worth checking that none of you CSS is effecting the ccm-page editor wrapper.

Does your browser inspector show any errors?

Thanks again for the tip. I found this in the inspector console:

Blocked loading mixed active content “”

Now I’m going to poke around to see what it means and what I can do about it.

Ahhh - there’s one other thing that has changed …

I run an apache proxy that sends the https: to the backend server as http - it’s worked fine in the past. What I’ve done recently is change the proxy to use let’s encrypt certs and made no change to the back end server.

As a quick test I’ll revert the proxy back to self-signed certs and if it then works - then we’ve got it cornered.

Thanks again for the poke in the right direction.

Can you log into the backend with https after enabling the SSL certificate?

It is now working when the proxy forwards the ssl to the backend as https. Right now I’ve got the front and back end both using self-signed certs.

So I’ll switch the proxy & backend to letsencrypt and fwd ssl to the back end as https.

Thank you very much for the help - I was stumped!

You are welcome. I’m glad I could be of some help.