Cannot edit the custom skin

I have a production site and two almost the same sites on my local computer which I use to test things.

On all 3 sites I cannot edit the custom skin I get error message when I go to the custom skin. The custom skin is the same in all 3 instances.

I tried to change the debugging mode to get more info and I got another error. One of my test sites does not work at all now.

All 3 site are 9.2.4

I did have the debugging mode set in one of my test sites and some of the errors pointed to a compiler and scss file - but I did not have time to take a screen shot. When I tried to change the debugging mode I got the error message above

Any ideas

The ‘Consider Warnings as Errors’ setting has resulted in what you are warned about in the red text. You will need to edit the config key in /application/config/concrete to clear it.

Hi thanks for the tip. The problem with the error settings only occurred in my test sites. I tried looking at /application/config/concrete.php but I could not see anything that looked like a “key”. Anyway irrelevant now I can easily re-install the test site.

My production site is still working ok - but the problem is I cannot edit the skin customization tab (see top screen shot) Can anyone help with this ?

I found these error messages in the logs if they are relevant ?

Exception Occurred: /home/meg/public_html/updates/concrete-cms-9.2.4-remote-updater/concrete/vendor/illuminate/filesystem/Filesystem.php:57 File does not exist at path /home/meg/public_html/application/themes/atomik/css/presets/default/_customizable-variables.scss. (0)

Exception Occurred: /home/meg/public_html/updates/concrete-cms-9.2.4-remote-updater/concrete/vendor/illuminate/filesystem/Filesystem.php:57 File does not exist at path /home/meg/public_html/application/themes/atomik/css/presets/default/main.scss. (0)

I have just checked that in my production site there is no /application/themes/atomik/css folder .

I developed the custom skin with Concrete 9.1.3 about one year ago, so there have been upgrades. The custom skin looks the same as always

hello again !

I managed to revive my test site by editing out the complete section on debugging in /application/config/concrete.php.
Unfortunately the issue of debugging has turned out to be a red herring in this post, I apologize for causing this problem.

On my revitalized test site I managed to take a screenshot of the full error message of the custom skin editing page which does not work this was the intended main issue of this post

I have the same problem on my production site this what I really want to fix.

My apologies again for casuing confusion with the debugging issue.

Could it be this issue?

From your debug screen, scroll down the top left panel to the bottom of the section until you see [COPY] and copy the debug trace into your PC clipboard.

Then, please either add your trace as a new post in the existing GitHub issue, or create a new GitHub issue. Also add your other evidence such as the screengrabs above.

That won’t provide an immediate solution, but may help the core team find a solution for the next monthly core update.

You might be using a skin built with an older version of Bedrock with a new version of Concrete? I know those issues don’t happen in the new version of Bedrock:


I am using the standard Atomik theme starting with version 9.1.3, and it has been updated to 9.2.4
I used only customization (colours, fonts etc) from the Atomik/Concrete backend. I did not introduce any code from anywhere , just using the facilities available in backend .

Here is the full error report from the screenshot above:

ScssPhp\ScssPhp\Compiler error
ScssPhp\ScssPhp\Compiler findImport
ScssPhp\ScssPhp\Compiler compileImport
ScssPhp\ScssPhp\Compiler compileChild
ScssPhp\ScssPhp\Compiler compileChildrenNoReturn
ScssPhp\ScssPhp\Compiler importFile
ScssPhp\ScssPhp\Compiler compileImport
ScssPhp\ScssPhp\Compiler compileChild
ScssPhp\ScssPhp\Compiler compileChildrenNoReturn
ScssPhp\ScssPhp\Compiler compileRoot
ScssPhp\ScssPhp\Compiler compileString
Concrete\Core\StyleCustomizer\Processor\ScssProcessor compileFileToString
Concrete\Core\StyleCustomizer\Compiler\Compiler compileFromPreset
Concrete\Core\StyleCustomizer\Compiler\Compiler compileFromCustomSkin
Concrete\Controller\Panel\Detail\Theme\PreviewSkin viewIframe
Concrete\Core\Controller\AbstractController runAction
Concrete\Core\Routing\ControllerRouteAction execute
Concrete\Core\Http\RouteDispatcher dispatch
Concrete\Core\Http\Middleware\DispatcherDelegate next
Concrete\Core\Http\Middleware\MiddlewareStack process
Concrete\Core\Http\DefaultDispatcher handleDispatch
Concrete\Core\Http\DefaultDispatcher dispatch
Concrete\Core\Http\Middleware\DispatcherDelegate next
Concrete\Core\Http\Middleware\FrameOptionsMiddleware process
Concrete\Core\Http\Middleware\MiddlewareDelegate next
Concrete\Core\Http\Middleware\StrictTransportSecurityMiddleware process
Concrete\Core\Http\Middleware\MiddlewareDelegate next
Concrete\Core\Http\Middleware\ContentSecurityPolicyMiddleware process
Concrete\Core\Http\Middleware\MiddlewareDelegate next
Concrete\Core\Http\Middleware\CookieMiddleware process
Concrete\Core\Http\Middleware\MiddlewareDelegate next
Concrete\Core\Http\Middleware\ApplicationMiddleware process
Concrete\Core\Http\Middleware\MiddlewareDelegate next
Concrete\Core\Http\Middleware\MiddlewareStack process
Concrete\Core\Http\DefaultServer handleRequest
Concrete\Core\Foundation\Runtime\Run\DefaultRunner run
Concrete\Core\Foundation\Runtime\DefaultRuntime run

I tired with my test site to change themes. I activated the elemental theme and got this

I can go to the customization tab and I can change and save colours

If I then go back to the Atomik theme then I get this

So it looks as if the page templates have disappeared. I still get the error messages when trying to edit the customization tab.

I am trying at the moment to re-install the page templates, but so far I have not succeeded.


My production site is the same, no page templates. I have tried adding templates in the backend
Dashboard>Pages&themes>Page Templates “add templates” but with no results.

Should I copy the pages from /concrete/themes/atomik/elements and paste ? If so where to past ? There is a directory /application/page_templates but this completely empty and there is /application/themes/atomik/elements which contains the footer.php files ?

Can anyone help here ?

I thought I might round off this post as I have found a solution.

To recap I had three sites, a production site which has been on line for about 1 month and 2 “test sites” on my local computer all based on the Atomik theme with the same custom skin.

The problem was that the custom skin facility in the standard Atomik theme stopped working and it was not possible make any changes to the customs skin as there was error (detailed above)

Also there were no page templates listed under the atomik theme, on all 3 sites.

On one of my tests site I tried I copying the page templates from /concrete/themes/atomik/elements to application/themes/atomik/elements - this worked on the test sites the list of available page templates reappeared in the Atomik theme (although it was still not possible to edit the customs skin). The same procedure did not work on my production site.

On all three of my sites it was possible to make and edit a custom skin with the Elemental theme.

My solution to this problem was to buy the Subatomik theme from the Concrete marketplace.

The installation went without problems, the transition was easy, and I had details of my original custom skin, so it took only a few minutes to recreate a replica of my original skin, hence very little down time.