Canonical URLS has disabled logging in - dont know where it is stored to change

I have just about finished a site, and am moving the real domain to the temp one.

I have managed to achieve this by using canonical URL in the SEO settings, but now when I log in, it attempts to validate against the wrong URL and I cant log in to change it.

I believe I can overcome this by changing the URL in the database but have no idea where it is stored.

Any help here would be greatly appreciated.

Take a look in the application/config/generated_overrides/concrete.php file for your seo settings

under SEO there was true for url_rewriting, changing to false didnt help. It does mention its a generated file in the head comment

what I can see is that its dropping the www whick makes it fail. if you add it in then the pages load but post to a non www url.

ive tried changing .htaccess file with no luck either

Try adjusting your seo statements to this

'seo' => [ 'redirect_to_canonical_url' => false, 'url_rewriting' => true, ],

1 Like

i have managed to use the CLI to set those -

    "url_rewriting": true,
    "url_rewriting_all": false,
    "redirect_to_canonical_url": false,

changing that and checking some of the server domain settings I seem to be back to getting the pages to work, but I am now getting in invalid token on login. Is there a way to regenereate?

UPDATE: its posting to a non www URL when everythong else is www

Thank you for you help @ConcreteOwl it was a combination of configuration, which I was able to reset via command line, incorrect server domain setup and .htaccess configurations.

All working fine for the moment.

Appreciate it.

1 Like

Your most welcome David