Can't add a form

New install on v9.0.2. Try to adda form - the modal window displays the following error. Do these forms actually work?? Or are they broken for the time being?

Undefined property: Concrete\Block\ExpressForm\Controller::$exFormID


|/home/mysite/public_html/beta/concrete/blocks/express_form/controller.php(902): Whoops\Exception\ErrorException->null||

Then about 20 other lines that look similar.

Concrete Version

Core Version - 9.0.2
Version Installed - 9.0.2
Database Version - 20220114215506

Database Information

Version: 10.5.13-MariaDB-cll-lve

Concrete Packages


Concrete Overrides

themes/warrenconstruction/css/build/_application.scss, themes/warrenconstruction/css/build/_footer.scss, themes/warrenconstruction/css/build/_forms.scss, themes/warrenconstruction/css/build/_header.scss, themes/warrenconstruction/css/build/_mixins.scss, themes/warrenconstruction/css/build/_reset.scss, themes/warrenconstruction/css/build/_variables.scss, themes/warrenconstruction/css/build/main.scss, themes/warrenconstruction/css/build, themes/warrenconstruction/css/hamburgers.min.css, themes/warrenconstruction/css/main.css, themes/warrenconstruction/css/, themes/warrenconstruction/css/normalize.css, themes/warrenconstruction/css, themes/warrenconstruction/elements/footer.php, themes/warrenconstruction/elements/header.php, themes/warrenconstruction/elements, themes/warrenconstruction/img/F54779E0E4343071.png, themes/warrenconstruction/img/form-bg.jpg, themes/warrenconstruction/img/ftr-bubbles.svg, themes/warrenconstruction/img/ftr-envelope-square.svg, themes/warrenconstruction/img/ftr-instagram.svg, themes/warrenconstruction/img/ftr-linkedin-with-circle.svg, themes/warrenconstruction/img/ftr-warrenco-logo.svg, themes/warrenconstruction/img/idx-hero.jpg, themes/warrenconstruction/img/idx-red-seal-bg.jpg, themes/warrenconstruction/img/idx-red-seal-crest.png, themes/warrenconstruction/img/WC-hdr-logo.svg, themes/warrenconstruction/img, themes/warrenconstruction/js/main.js, themes/warrenconstruction/js/plugins.js, themes/warrenconstruction/js/vendor/modernizr-3.11.2.min.js, themes/warrenconstruction/js/vendor, themes/warrenconstruction/js, themes/warrenconstruction/default.php, themes/warrenconstruction/page_theme.php, themes/warrenconstruction/thumbnail.png, themes/warrenconstruction/full.php, themes/warrenconstruction

Concrete Cache Settings

Block Cache - Off
Overrides Cache - Off
Full Page Caching - Off
Full Page Cache Lifetime - Every 6 hours (default setting).

Server Software


Server API


PHP Version


PHP Extensions

bcmath, bz2, calendar, Core, ctype, curl, date, dom, exif, fileinfo, filter, ftp, gd, gettext, gmp, hash, i360, iconv, imap, json, libxml, litespeed, mbstring, mcrypt, mysqli, mysqlnd, openssl, pcntl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, posix, readline, Reflection, session, shmop, SimpleXML, sockets, SPL, sqlite3, standard, tokenizer, xml, xmlreader, xmlwriter, xsl, zip, zlib

PHP Settings

max_execution_time - 30
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 80
max_input_vars - 1000
memory_limit - 256M
post_max_size - 8M
upload_max_filesize - 2M
zend.exception_string_param_max_len - 15
mbstring.regex_retry_limit - 1000000
mbstring.regex_stack_limit - 100000
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - no value
session.gc_maxlifetime - 7200
unserialize_max_depth - 4096

Same issue here. Using legacy form for now but would like to know how to fix this.

I had the very same error but then when I tried it again with just a couple of fields on the form it worked… I then went to edit and add the other fields…
But it surely looks like a bug because when I go under Dashboard>System & Settings>Express>Data Objects I see multiple entries for the form.
Anyway that’s how I managed to get my form up

This seems to be a bug! I’m not sure how to et it reported.
Can someone help?
We obviously all have found workarounds but it is annoying and in my case requires going back and deleting all the unnecessary duplicate entries in “Dashboard > System & Settings > Express > Data Objects”


Bug in original post is typical php8 bug spread across many concrete5 blocks. It being worked on for some time. So you need to wait till all bugs like that will be fixed or downgrade to php 7.4.

PHP8 is not officially supported by concrete5 yet.

Thanks for the reply
I’m on PHP 7.4 so it must b something else…
I’ll look out for the bug fixes. Any idea when to expect v9.03?

COuld you modify the file concrete\blocks\express_form\controller.php at the end where you have the method getFormEntity() and modify it to look like this:

protected function getFormEntity()


    if (isset($this->exFormID) && $this->exFormID) {
        $entityManager = $this->app->make(EntityManagerInterface::class);
        return $entityManager->getRepository(\Concrete\Core\Entity\Express\Form::class)

    return null;

It should fix the issue.