Can't delete an external link in sitemap

Does anyone know why I’d be having trouble deleting an external link from the Sitemap? When I click on the link and choose “Delete” from the popup menu, it takes around 30 seconds but eventually an error message pops up -

" Error 500 - Internal Server Error

An error was encountered while processing your request. Typically this is a temporary condition. Please contact the web site owner for further assistance."

And it will not delete.
Any ideas for me out there?

have you tried clearing the cache, might help

Thanks for responding, but, yes, I have cleared cache and also messed with exchanging PHP versions. No change. The attached image shows a portion of my sitemap. Notice the icon difference between the two circled. I was training on how to create a new page from an existing one. So, I did a “drag and drop” of the Newsletter External Link file onto the Foundations Page and chose “Copy” from the popup menu that shows when you do that. I later moved the two files to the bottom under the folder “Testdelete”. I now want to delete these. When I click on one of them, only two options appear on the popup menu - Visit and Delete. If you click Delete, a confirmation window pops up and I click delete on that. Then it churns away until finally displaying an “Internal Server Error - 500”. Can’t get rid of them.


I created a new “Newsletter” External Link by copying the original. Does anyone recognize or know why the icon would change or why the copy would limit my options on the popup menu? See images below for menu differences.


Hi @Pixelfixer - tried to reproduce this in 8.5.9 but deleting the External Link seemed to work - can you let me know what version of PHP and Concrete you’re running? Thanks.

@Pixelfixer the icon is an alias. On version 9+, the menu should have the “Edit Alias” option:
Screenshot from 2022-09-06 11-54-11

What version of Concrete are you using?


I’m using 5.8.9 version of Concrete on this site. The links I couldn’t delete were in a hidden folder for test files and so deleting them wasn’t critical. But when I logged back in to try something else, they were not there. I’m not sure what happened. Maybe my client tried a few things and found a way to clear them? I know I didn’t. Anyway, it’s no longer a problem on this site. I haven’t seen it before or since, so I hope it was just some sort of anomaly and I won’t see it again. :slightly_smiling_face:

1 Like