Can't load Clipboard

When I click the down arrow, I see Blocks, Clipboard and Stacks, but if I click Clipboard, it just goes back to Blocks or Stacks. Any idea why? It has always worked until now.

Sometimes a faulty block copied into the clipboard can break it. If that is the case, there would be something in the browser developer console.

I looked in my Chrome Developer Console, and when I click on Clipboard it says “jquery.js?ccm_nocache=d846f33d9148b37e63b22ff9a7339155be77a7f9:4 GET 500 (Internal Server Error)”
Does that mean that the server is blocking access to my clipboard for some reason?

No, that means a php error has occurred when the server tried to render one of the blocks in the clipboard. If you look at the developer console network tab, in the XHR section there may be a full stack trace that will identify the block type in question.

Thanks John - I’ve found this:

I’m not a programmer, so I don’t know what to do with it! Any tips?

Click on the 500 line and look at the preview or response tabs that are then shown. These may include expander triangles, so then expand all the way and then copy/paste.

Whilst this may help identify the source of the problem, there is no guarantee that it will be fixable through forum posts.

Thanks for your help, John. I think this one is beyond me! I did as you suggested, and got nothing more than 0: “An error occurred while processing this request.” I shall seek help from my IT technician next time I see him! Meanwhile, I can manage without the clipboard. I just don’t like things being broken.

If it is a block in the clipboard that is faulty, clearing the clipboard completely would resolve the immediate problem.

My Extreme Clean - concrete5 addon includes a clipboard cleaner.

Just realised you are in Brisl :slight_smile: . I am in Clifton.

What are the chances of that? It’s a small world! I’ll take a look at Extreme Clean. Thanks again.

Another potential fix may be to prevent the block rendering in edit mode:

// Show "Disabled in edit mode" panel
$c = Page::getCurrentPage();
if ($c->isEditMode()) { ?>
 <div class="ccm-edit-mode-disabled-item" style="<?php echo isset($width) ? "width: $width;" : '' ?><?php echo isset($height) ? "height: $height;" : '' ?>">
        <div style="margin-top: 300px; padding: 100px 0px 100px 0px"><?php echo t('MSM Ajax Slider disabled in edit mode.')?></div>
<?php } 
else { ?>

[Block output here]

<?php } ?>

Yes, that can be a good solution once the block concerned has been identified.
If it is a custom block whose normal behaviour interferes with the clipboard or edit mode, that is a good solution.

At present, the offending block has not been identified.

Such problems can also arise from block content, such as mis-matched tags or a dodgy script pasted into an HTML block. My ‘Safe HTML’ template for the HTML block uses the same isEditMode() test. Using the ‘Safe HTML’ template or similar can prevent the root issue from breaking something else (the clipboard), but will rarely resolve the root cause.