Can't Move Blocks -- CSS for the edit block menu seems to be overtaking move icon

Using the Concrete 9.2.1 recently upgraded but so far everything else has been working and this was an issue prior to being on 9.

If I am in edit mode and try to click on the move icon when hovering, it doesn’t “grab” the block it just selects.

If I click the block I get the block “right click style” menu. The only way to move it is if I click to get the block menu and then click in the block close to where the move icon would be and then -very- quickly click and hold to move.

I’ve tried to mess with Z-index on the two classes (ccm-menu-click-proxy and ccm-edit-mode-inline-command-move) but to no avail. I’ve also looked into my theme but am not seeing anything conflicting.

Any thoughts?

What theme are you using? I’ve been having intermittent issues also and seem to be theme-related.

It’s a custom theme that was purchased at some point but was an HTML theme. I converted to a concrete theme a long time ago and keep updating it through the versions.

So far this is the only issue.

can you zip it and attach it here so I can have a look
you can email it if you like:

I remember converting an older theme into version 9, I had the same problem. In pagetheme.php, I loaded jquery and/or bootstrap from the core into the theme. Then it worked. Try.

public function registerAssets() {
    $this->requireAsset('javascript', 'jquery');

Ooh, going to try this. Thanks much!

Hi, I tried your pagetheme settings, - no luck.
I can move blocks when I sort of doubleclick on the move icon, then it works. But normally the cursor won’t change when hovering over the move icon - similar to @alwsfail’s experience in 1st post. Very annoying.

Where’s the bug?

If you have CSS with z-index attached to the block you might run into these problems. Remove it and try again.


That’s it!
I had z-index: 1; on the block for no reason. Now I can move blocks easily, the cursor even changes to green when hovered.
Thanks a lot.

1 Like