Can't undo theme bug

So, I messed up and forgot to change Concrete/Theme/Mytheme to Application/Theme/Mytheme, so when I installed the theme is obviously crashed with the “Target class [\Concrete\Theme\Mytheme\PageTheme] does not exist.” error. So I fixed it, but now it still has the same error. I have wiped the cache, so, where is this old piece of data stored? It is not in the database either. Or, I there another way to back out of this? This is on C5 9.1.1. Thanks

@ntisithoj Maybe this nifty clone / will do the trick, or help with your troubleshooting

I would start with manually clearing the site cache and clearing your browser cache. Also make sure your your theme folder name and namespace theme name are identical. The namespace path is case sensitive

1 Like

FWIW, I temp fixed the problem by editing concrete/src/Page/Theme/Theme.php and changing line 118 from
$r = $db->query(‘select pThemeID from PageThemes’ . $where);
$r = $db->query(‘select pThemeID from PageThemes’ . $where. ’ limit 1’);

Then perm fixed with a SQL command “delete from PageThemes where pThemeID = 3” then undid changes to Theme.php. Not sure if it is safe to do that directly to the DB, but nothing else seemed to work.

Thanks for that link.
I saw that link before, but honestly, it confused me because Atomik doesn’t use anything in packages, but I guess rock_solid does? I also have no idea what rock_solid is. Is it a clone of Atomik_clone (?). Is it a branch of Atomik? When the instructions for cloning included installing and configuring/building a bunch of npm/js/laravel/bedrock stuff, I chose to skip it because cloning a theme should not take that much effort and be so heavy that I’d need to run an npm monitor to check the status of massive compilations, plus, on 9.1.1, installing the CMS from the command line crashes miserably, so, it seemed like I was inviting more problems with this solution.