Change resources directory

I’m playing around with the ‘resources’ section in version 9.2. I don’t want the title to be resources, i want it to be information.

I’ve changed the containing page name from ‘resources’ to ‘information’.
All pages that were under resources (Resource One, Resource Two etc.) are still inside that directory.
When I view the top level page now called ‘information’, the pages list block shows a preview of all those sub pages as before, however, if I click on any page it shows ‘Page Not Found’.
When I look at the URL its showing index.php/resources/Resource One, rather than index.php/information/Resource One.
How do I alter things so its searching in the right directory i.e. ‘information’ not ‘resources’?

Have you tried clearing cache in dashboard?

My guess is that you didn’t change the URL Slug when you changed the name of the page. Also, clean up the ‘Location’ so it doesn’t include old paths.


hi enlil, yes i did try that thanks.

hi mhawke, I did change the url slug thanks.

You might run reindexing tasks in the dashboard and then clear the cache.

I’ve had this issue on two different sites now too. If you change the URL Slug for a parent, the children are given the URL but it is not the canonical. So when you have a pagelist, it shows the old URLs for the children. I’ve just had this happen again and so I went through each child page (30+) and changed the canonical URL in the ‘Location’ options for the page. After I manually set all of the canonical URLs to match the new parent slug, then rebuilt the indexes, only then did the pagelist reflect the correct URLs.

Yeah that might make a good quality of life issue to post if it isn’t already: