Configuring Canonical URLs

I’m using Concrete Version 8.2.1 and trying to get my head around Canonical URLs (I’m not a web expert by any means). Google Search is not indexing my pages because of “Duplicate without user-selected canonical” on many pages. I tried to add the canonical url (e.g. as it’s in the conc8 subfolder) in the SEO URL and Redirections settings but it doesn’t seem to work. Do I also need to tick the “URL Redirection” box and why?

I put a canonical link reference in the Tracking code but this just sets the same canonical URL for every page. I know I must be making some simple mistake as I’m sure it can’t be that complicated. Any advice would be much appreciated.

Thanks in advance,

You can turn on canonical urls by selecting the last option at /dashboard/system/seo/urls

1 Like


Do I need to put the “/conc8” subdirectory in the URL?

I also have a few other domain names that permanently redirect to this site. Will these still work if I click the URL Redirection checkbox?

Thanks again.

honestly, being that it’s a subdirectory, I can’t comment on how it should work. You may or may not have an issue there. Hopefully someone can chime in with more specific info for you…

1 Like

Yeah I would recommend using a Subdomain rather than a subdirectory if you have to go that route. But like @enlil mentioned, it’s probably best not to run this from a subdirectory.

You should also update to the latest version of Concrete, or at least the latest version of v8 - otherwise you may be running into bugs that have since been fixed.