Corrupt Install

I have a website where I’m getting the following exception trying to install any add-on

“Unknown column type “json” requested. Any Doctrine type that you use has to be registered with \Doctrine\DBAL\Types\Type::addType()”

I get the same error when I attempt to refresh the Database Entities.

Everything else seems to be working correctly except in the dashboard there is an option for “Boards” that I haven’t seen before. However, the page doesn’t actually exist.

Obviously something has gotten corrupt. Any ideas?

Take a look at the file ‘Type.php’ in concrete\vendor\doctrine\dbal\lib\Doctrine\DBAL\Types
You should see ‘public const JSON = Types::JSON;’
And Possibly ‘public const JSON_ARRAY = Types::JSON_ARRAY;’

Thanks @ConcreteOwl!

So looks like v < 9 uses Doctrine/DBAL v 2.5.13 which does not include the JSON type. I upgraded to v 2.6.3 which solved my immediate problem.

I think the underlying issue is with this project we were considering going with v9 but we decided against it. We must have run some sort of partial upgrade or something at some point. Not really sure. Now that I can install the migration tool plugin I think I’m going to rebuild the site when I get a chance.