Elements in Header not showing

We have the problem, that in the header the logo and also the language selection are visible and editable in the programming preview, but neither are visible in the browser.
It’s exactly the same with the footer. The footer text is in, but finally not visible.

The link to the site is this: deutsch :: Free Walking Tour

We already tried clearing cache, which didn’t help.

The problem could have something to do with the multi language site, since the problem wasn’t there before we created the multi language options.

If you can help, I could send login details for a temporary account via email or personal messager.

Visit this page in dashboard:
Dashboard → Stacks & Blocks → Stacks & Global Areas → Global Areas

Click “your logo” global area.

Click “your logo” in breadcrumbs at the top of page. It should list multilingual versions of currently global area. Check if “Default section” or language section is filled with proper content.

Could be also something with permissions, if only admin can see it.

Thanks, for your reply.

I’ve set up the multilingual versions of the global areas, but still, nothing there is visible in the browser.

Where can I change the permissions, so not only admin can see it, if that is what’s causing the problem?

In the same place (global areas). There is Permissions link there in a bar. You can also set permission for each block inside global area.
“Guest” group should be added to “View” action.

There can be also something hard-coded in php files/templates, if you are using custom template.

Thanks for your reply, but I don’t think I can find the setting you are referring to.
Would you be willing to work directly on the site to fix the problem?

If you send me your email address, we can set up a temporary account for you to work on.
Just let us know how much you would like to be paid for the task.

Send me credentials in private message and I’ll glance at if it is not something obvious and if further research is required.

you have disabled private messages, so
unlock it or send me message using contact form.


I’ve enabled private messages now.

Sorry I wasn’t aware they where turned off.

I’m posting this here for anyone having the same problem.
It was indeed an issue with the permissions.

This is what solved it:

"Click Options → Include system pages in sitemap → left click “Stacks” → Permissions
All checkboxes were unchecked.

a) Who can view this page? - Guest
b) Who can edit this page? - Administrators"