Error: Unable to get category for permission search_file_folder

Hello Team,

I am getting this error when upgrading from version to 8.0.0. Please assists me or guide me to fix this issue.


Are you going to version first, then V8?

No Mesuva, I am trying V8 directly. I am new to this upgrade process. Can you please provide me some Ideal steps to process this upgrade?


The standard practise with upgrading major versions of Concrete is to upgrade to the latest of the major version the site is on first, then do the major version upgrade.

So you should be able to go from to, and then do V9.

Keep in mind that 5.7 upgrades have to be triggered. I normally log into a site first, then swap out the concrete folder, and visit /index.php/ccm/system/upgrade

But with V8, simply dropping in the new folder and visiting the site with trigger the upgrade immediately.

I’d suggest following the instructions at
How to Upgrade Concrete5 under the ‘Replacing the original Concrete Directory (Version 8 and above)’ section and the ‘Replacing the original Concrete Directory ( and earlier) sections’

For larger sites, I will often do the upgrade locally and push up the full site again. Or I’ll at least test the upgrade locally.

One tip is to adjust some PHP options to allow the upgrade to complete successfully. Often the upgrade will just take a lot of time to process, so it can time out. I will (using cPanel or equivalent) adjust the PHP settings to set a very long timeout (10 minutes), and make sure the memory limit is set high enough.

Thank you, let me try the standard process of the Major upgrade.


I tried the above steps and I am getting the same error, please assist me with this error in the upgrade process


Unable to get category for permission search_file_folder

It may be some previous upgrade failed and there’s some inconsistency that the upgrade is tripping up on.

The only thing I’ve found from searching this error is the suggestion to check your PermissionKeys database table, for an entry with the pkHandle of search_file_folder

Here’s the line from a recent install I have:

INSERT INTO 'PermissionKeys' (
    'pkHandle', 'pkName', 'pkCanTriggerWorkflow', 'pkHasCustomClass', 'pkDescription', 'pkCategoryID', 'pkgID'
    'search_file_folder', 'Search File Folder', 0, 0, 'See this file folder in the file manager', 5, 0

I’d check if exists, and if it doesn’t you could try adding it before the update to V8. In my database the ID of that entry is 40, but I’ve removed it from the query above in case you wanted to run it.

Thank you mesuva,

When I tried to Insert this query and I am getting this error. #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '‘PermissionKeys’ (‘pkHandle’, ‘pkName’, ‘pkCanTriggerWorkflow’, ‘pkHasCustomClas’ at line 1

Please let me know if anything need to changed in the query

The formatting from the forum was causing a few issues, try this:

INSERT INTO `PermissionKeys` (`pkHandle`, `pkName`, `pkCanTriggerWorkflow`, `pkHasCustomClass`, `pkDescription`, `pkCategoryID`, `pkgID`) VALUES ('search_file_folder', 'Search File Folder', 0, 0, 'See this file folder in the file manager', 5, 0);

The query worked so after I tried to Install the V8 and got the same error Unable to get category for permission search_file_folder

Sorry to hear it didn’t work. I unfortunately don’t have any other suggestions at this point, you may need to seek out an experienced Concrete developer to work through the issue, work out what is going wrong, etc.

Ok Thank you. Do you know anything on this error.

Class ‘Application\Src\Helpers\Index Search Helper’ not found

Getting the class not found error in the V8

You should probably start a new topic for this issue since it’s unrelated to this topic.`

What are the exact steps you took to upgrade? There’s not enough information here to really offer any help.


I spent some time installing (which is not easy to do since it uses an old, unsupported version of PHP), and then added 8.0.0 to the /updates directory.

I see there is a clear warning that this type of upgrade is not recommended:
Screenshot from 2021-09-09 16-20-44

Also, the upgrade notices explain the steps you should take:
Screenshot from 2021-09-09 16-20-54

So I’d recommend you restore from a backup and follow those instructions.

Thank you for the information. I have processed the upgrade first to this version and it was successful. After that I tried to upgrade it to Version 8 and my PHP version is 7.1.
I followed steps in the document “Replacing the original Concrete Directory (Version 8 and above)”
Please assist me on this upgrade issue