Express, filterByAttribute, not working for Author?

I’m trying to filter an EntryList object by the Author default Attribute in an Express Object, but PHP is throwing errors…

$durrdurrEntity = Express::getObjectByHandle(‘durrdurr’);
$listdurrdurr = new Concrete\Core\Express\EntryList($durrdurrEntity);
$listdurrdurr->filterByAttribute(‘author’, $uID);


Unable to find attribute author



I tried uppercase Author and lowercase author, and neither work. I’m not seeing why this is breaking… Also $uID is defined earlier as the ID for the logged-in user, so it’s an integer value.

It’s because you didn’t camel case durrDurr! :wink: jk

Have you tried on the latest version of version 8? Looks like you’re rolling 8.5.7 there - 8.5.12 might have that resolved.

Otherwise might try it on v9 and consider a further jump.

Well I don’t mind bumping the version, but also one of the reasons I posted about this is that I might just be trying to refer to the Author attribute “the wrong way”. Since I can’t find any documentation on that specific attribute and expected syntax, I entertained the possibility I was doing it wrong. And I may still be doing it wrong.

That being said, are you able to reproduce the issue with any 8.5.x version? My searches didn’t really turn up other people having the same problem, so I suspect this also may just be an uncaught bug.

Oh, also, no worries about the jokes :stuck_out_tongue_winking_eye: I’m all about that Camelcase XD and for all I know it could have been something silly like that

1 Like