Fatal error while installing


today I wanted to check out the concrete CMS for the first time. But I already got stuck while installing the database.

Fatal error: Declaration of Concrete\Core\Messenger\Transport\Sender\SenderLocator::get($id) must be compatible with Symfony\Contracts\Service\ServiceProviderInterface::get(string $id): mixed in E:\wamp64\www\xxxxxxxxxxxxxx\public\concrete\src\Messenger\Transport\Sender\SenderLocator.php on line 17

Using PHP 8.2.13.

Tried on XAMPP and WAMP, same error. I guess it’s a Symfony related problem?

Did you download an official release, or did you install things from github?

I installed from composer

Try the release on the download page: Download :: Concrete CMS - Org

Whilst the composer version is supposed to work, there are many libraries that are pulled in, and perhaps some combination of libraries is causing an install issue right now.

An official release on the other hand, is going to be a fixed set of dependencies.

Ok, that worked, thank you!

This problem has been fixed by Fix #11869 · concretecms/concretecms@f8672bd · GitHub (which will be be included in next Concrete v9 version).

In the meantime, if you want to install Concrete with composer, you have to add this line to the require section of your composer.json file:

"symfony/service-contracts": "^2.5"