Forms broken on whole site

EDIT: This problem is sitewide. Tested a different form on the main site and got the same behavior and this error.

“You do not have access to submit this form.”

The form renders just fine but when submitting, it doesn’t save the form data and it goes to a URL like “submit/2020#form2020” then loads the content of the home page on my main site even though the URL is still the microsite URL.

This issue occurs regardless if I have the setting for redirecting to a “thank you” page. This is the microsite (form is hidden right now since it doesn’t work). Attached you can see how it loads the content of the main page after submitting the form.

Concrete Version

Core Version - 9.2.1
Version Installed - 9.2.1
Database Version - 20230503095900





Database Information

Version: 8.0.35-0ubuntu0.20.04.1

Concrete Packages

Block Builder (2.4.0), Modena Theme (2.1.7), Open Graph Tags Lite (2.1.6)

Concrete Overrides

blocks/form/templates/referral.php, blocks/form/templates, blocks/form, blocks/vidal_themes_offscreen_hero/templates/half.php, blocks/vidal_themes_offscreen_hero/templates, blocks/vidal_themes_offscreen_hero, blocks/vidal_themes_hero_unit, blocks/vidal_themes_tabs/templates/accordion/view.php, blocks/vidal_themes_tabs/templates/accordion, blocks/vidal_themes_tabs/templates, blocks/vidal_themes_tabs, blocks/page_list/templates/projects.php, blocks/page_list/templates, blocks/page_list, blocks/cta/scrapbook.php, blocks/cta/config-bb.json, blocks/cta/db.xml, blocks/cta/composer.php, blocks/cta/icon.png, blocks/cta/add.php, blocks/cta/controller.php, blocks/cta/css_files/form.css, blocks/cta/css_files, blocks/cta/edit.php, blocks/cta/view.php, blocks/cta/form.php, blocks/cta, themes/landing_home.php, themes/elements/landing_header.php, themes/elements

Concrete Cache Settings

Block Cache - Off
Overrides Cache - Off
Full Page Caching - Off
Full Page Cache Lifetime - Every 6 hours (default setting).

Server Software

Apache/2.4.57 (Unix) OpenSSL/1.1.1f

Server API


PHP Version


PHP Extensions

bcmath, bz2, calendar, cgi-fcgi, Core, ctype, curl, date, dom, exif, FFI, fileinfo, filter, ftp, gd, gettext, gmp, hash, iconv, imap, intl, json, ldap, libxml, mbstring, mysqli, mysqlnd, odbc, openssl, pcntl, pcre, PDO, pdo_dblib, pdo_mysql, PDO_ODBC, pdo_pgsql, pdo_sqlite, pgsql, Phar, posix, readline, Reflection, session, shmop, SimpleXML, snmp, soap, sockets, sodium, SPL, sqlite3, standard, sysvsem, tidy, tokenizer, xml, xmlreader, xmlrpc, xmlwriter, xsl, Zend OPcache, zip, zlib

PHP Settings

max_execution_time - 30
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - -1
max_input_vars - 5000
memory_limit - 256M
post_max_size - 1024M
upload_max_filesize - 512M
ldap.max_links - Unlimited
mbstring.regex_retry_limit - 1000000
mbstring.regex_stack_limit - 100000
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
odbc.max_links - Unlimited
odbc.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
pgsql.max_links - Unlimited
pgsql.max_persistent - Unlimited
session.cache_limiter - no value
session.gc_maxlifetime - 7200
soap.wsdl_cache_limit - 5
unserialize_max_depth - 4096
opcache.max_accelerated_files - 4000
opcache.max_file_size - 0
opcache.max_wasted_percentage - 5

Updated to version 9.2.2 and the problem is still there.

Hi @wishborn - do you have any permissions set on the Express object this form is submitting to?

The next thing I would look at is if the overrides to the form block or the form block templates (blocks/form/templates, blocks/form) are creating issues - you might try removing them and seeing if the forms perform as expected without them - that would help narrow down the issue.

1 Like

I am not sure where I would set permission on Express objects but this was working last I tried it a couple of months ago. I am using the Modena theme and the templates they had. In changed it back to Default and now I get this error.

I disabled the Captcha and I still get the access error.

the only place I can find reference to permissions in relation to the Express object is in the Custom Entry Points UI. I have it set for Guests to be able to Add.

That is curious - those permissions do look correct from what I can see (the permissions on those parent nodes would be of interest as well).

I did find this forum post from the archives that looks like a similar issue:

Perhaps a workaround for now would be to recreate the form from a form block and see if that behaves better.

Thank you for the time to assist with this Evan, concrete is always my preferred CMS and I proudly display what the site is built on in the footer.

The Permissions on Parent are the same, however, the permission on the Entities node was set to not allow Guests to Add Entry but to View them, the Forms node was set to Override and had what you see in my last post, so concrete doesn’t seem to be honoring the override. Setting the Entities node back to defaults switching the form node to inherit, this fixed the form on the main site that is in my global footer, but the Form (that is not in a global area), on the microsite still exhibits the same behavior, (nothing saved and it loads main site content).

This form was created using the Form block.

I get this problem even if I am logged in as Admin and it happens on all of the sites.

This is issue is a major issue now. Since concrete isn’t able to work the way it’s supposed to, I will be forced to look at using alternative solutions