Getting Error after waiting for installation to complete

I downloaded newest version yesterday, went to install today, waited forever and after 10 minutes of creating tables, got this error, database obviously was empty when I started, any ideas??

============================================================

There are already 348 tables in this database. Concrete must be installed in an empty database…

Trace:
#0 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Package/StartingPointPackage.php(184): Concrete\Core\Package\StartingPointPackage->install_database() #1 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/controllers/install.php(390): Concrete\Core\Package\StartingPointPackage->executeInstallRoutine(‘install_databas…’) #2 [internal function]: Concrete\Controller\Install->run_routine(‘atomik_full’, ‘install_databas…’) #3 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Controller/AbstractController.php(318): call_user_func_array(Array, Array) #4 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Routing/ControllerRouteAction.php(64): Concrete\Core\Controller\AbstractController->runAction(‘run_routine’, Array) #5 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/RouteDispatcher.php(37): Concrete\Core\Routing\ControllerRouteAction->execute(Object(Concrete\Core\Http\Request), Object(Concrete\Core\Routing\Route), Array) #6 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/Middleware/DispatcherDelegate.php(39): Concrete\Core\Http\RouteDispatcher->dispatch(Object(Concrete\Core\Http\Request)) #7 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/Middleware/MiddlewareStack.php(86): Concrete\Core\Http\Middleware\DispatcherDelegate->next(Object(Concrete\Core\Http\Request)) #8 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/DefaultDispatcher.php(127): Concrete\Core\Http\Middleware\MiddlewareStack->process(Object(Concrete\Core\Http\Request)) #9 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/DefaultDispatcher.php(60): Concrete\Core\Http\DefaultDispatcher->handleDispatch(Object(Concrete\Core\Http\Request)) #10 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/Middleware/DispatcherDelegate.php(39): Concrete\Core\Http\DefaultDispatcher->dispatch(Object(Concrete\Core\Http\Request)) #11 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/Middleware/FrameOptionsMiddleware.php(39): Concrete\Core\Http\Middleware\DispatcherDelegate->next(Object(Concrete\Core\Http\Request)) #12 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/Middleware/MiddlewareDelegate.php(50): Concrete\Core\Http\Middleware\FrameOptionsMiddleware->process(Object(Concrete\Core\Http\Request), Object(Concrete\Core\Http\Middleware\DispatcherDelegate)) #13 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/Middleware/StrictTransportSecurityMiddleware.php(36): Concrete\Core\Http\Middleware\MiddlewareDelegate->next(Object(Concrete\Core\Http\Request)) #14 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/Middleware/MiddlewareDelegate.php(50): Concrete\Core\Http\Middleware\StrictTransportSecurityMiddleware->process(Object(Concrete\Core\Http\Request), Object(Concrete\Core\Http\Middleware\MiddlewareDelegate)) #15 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/Middleware/ContentSecurityPolicyMiddleware.php(36): Concrete\Core\Http\Middleware\MiddlewareDelegate->next(Object(Concrete\Core\Http\Request)) #16 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/Middleware/MiddlewareDelegate.php(50): Concrete\Core\Http\Middleware\ContentSecurityPolicyMiddleware->process(Object(Concrete\Core\Http\Request), Object(Concrete\Core\Http\Middleware\MiddlewareDelegate)) #17 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/Middleware/CookieMiddleware.php(35): Concrete\Core\Http\Middleware\MiddlewareDelegate->next(Object(Concrete\Core\Http\Request)) #18 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/Middleware/MiddlewareDelegate.php(50): Concrete\Core\Http\Middleware\CookieMiddleware->process(Object(Concrete\Core\Http\Request), Object(Concrete\Core\Http\Middleware\MiddlewareDelegate)) #19 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/Middleware/ApplicationMiddleware.php(29): Concrete\Core\Http\Middleware\MiddlewareDelegate->next(Object(Concrete\Core\Http\Request)) #20 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/Middleware/MiddlewareDelegate.php(50): Concrete\Core\Http\Middleware\ApplicationMiddleware->process(Object(Concrete\Core\Http\Request), Object(Concrete\Core\Http\Middleware\MiddlewareDelegate)) #21 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/Middleware/MiddlewareStack.php(86): Concrete\Core\Http\Middleware\MiddlewareDelegate->next(Object(Concrete\Core\Http\Request)) #22 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Http/DefaultServer.php(85): Concrete\Core\Http\Middleware\MiddlewareStack->process(Object(Concrete\Core\Http\Request)) #23 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Foundation/Runtime/Run/DefaultRunner.php(125): Concrete\Core\Http\DefaultServer->handleRequest(Object(Concrete\Core\Http\Request)) #24 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/src/Foundation/Runtime/DefaultRuntime.php(102): Concrete\Core\Foundation\Runtime\Run\DefaultRunner->run() #25 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/concrete/dispatcher.php(45): Concrete\Core\Foundation\Runtime\DefaultRuntime->run() #26 /home/sitesmad/madewithmylove.com/draft-site/concrete-cms-9.1.0/index.php(2): require(’/home/sitesmad/…’) #27 {main}

If you accidentally (or while waiting for something to happen in frustration) clicked twice…

You need to clear out the database before trying again.

There was an issue along these lines a few months back, so if trying again fails again, you could look back through the forums and GitHub for similar and see what the resolution was.

1 Like

I’ve run into this more often than not. You’ll have to remove the database and try again. I seem to recall upping the max execution time on my server helped…

1 Like

Thank you JohntheFish, I don’t think I did, but I did delete everything and start over and this time it did install!

PS. I didn’t create cranial urls when I installed, is there a way to do it now?

Did just that and it worked second time, thank you!

1 Like

You can at /dashboard/system/seo/urls

1 Like

Thank you , I have a question just to be sure I am asking the right thing, maybe I am not understanding what cranial urls are, currently my site address is:

https://madewithmylove.com/draft-site/concrete-cms-9.1.0/index.php

I want it to be:
https://madewithmylove.com/draft-site/index.php

Is there a way to do it? Do I type in that at the place you pointed out, I don’t want to manually have to fix it?

That is not canonical URLS, though they can have a bearing.

Before setting canonical URLS or ‘remove index.php’ you need to resolve where your site is on the web server.

You could just move all the directories and files currently inside /draft-site/concrete-cms-9.1.0/ up to /draft-site/, then delete the now empty directory (check first) /draft-site/concrete-cms-9.1.0/

Or you could achieve the same by moving the entire /concrete-cms-9.1.0/ up one level to sit alongside /draft-site/, delete the now empty /draft-site/ directory, then rename /concrete-cms-9.1.0/ to /draft-site/

If your web server supports subdomains, you could alternatively create the subdomain draft-site.madewithmylove.com and point that at the /draft-site/concrete-cms-9.1.0/ directory.

Tried both ways and now have empty page unless I change back to the original URL, tried a couple of times:


do you think it is cache, I did clear my browser cache a few times, using firefox, newest version.

More likely you missed something. There could be .dot files that are hidden. There could be different directory permissions.