Image slider not displaying in all browsers

I recently upgraded Concrete5 to version. 9.0.2. Since doing so, the image slider on my site’s home page is no longer working in all browsers. It works in Safari, but not in Chrome or Firefox. I have cleared the cache in those two browsers, but that did not help.
Any assistance much appreciated! Here is the site:

Your site is using mixed content, https for the domain and http for the links to the images.
If you change the links from http to https it will work.

Thank you for this suggestion!
I have been looking around for ways to do this, but not figuring it out.
Any guidance appreciated - very inexperienced!

Setup your canonical urls at Dashboard > System & Settings > SEO & Statistics > URLs and Redirection.

Thanks again! I’ve set the canonical URL as https
I get the following message:

Settings Saved.
It was not possible to detect your server kind. Here’s the configuration section for every supported server: please manually remove the applicable one from your server configuration.
For Apache

RewriteEngine On
RewriteBase /site/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule . index.php [L]

For nginx
location /site/ {
try_files $uri $uri/ /site/index.php?$query_string;

Not sure what to do about this… Is this in .htaccessfile? Somewhere else?

Interestingly, the image slider works on the homepage for some browsers and not others. On browsers where the slider doesn’t appear on the homepage, they do on other pages within the site… Having a hard time figuring this out!

Hi ConcreteOwl,
Further searching led me to a thread where you responded to another user with the same question… I have added that bit to the htaccess file and it seems to be working. Fingers crossed. Thanks for you all your help.

You are welcome, that is the power of the concretecms forum