Just enabled https for my Concrete site and its broken the navigation menu - mixed content?

Hi, I’ve just enabled https SSL for my Concrete website, but Firefox has block the dropped down menus as it reports them as mixed content.

Any ideas how to fix it please?

If you post the website address it will allow us to look for your mixed content and offer advice.

Look in Dashboard > System & Settings > SEO & Statistics > URLs and Redirection and make sure your are declaring https in the canonical setting

Just had an email that the community flagged my url’s as spam? I only pasted them as requested to try and get some help? Am i able to add the website link without it being hidden or removed?

i’ve tried adding the https url as the SSL canonical but it’s not made any difference.

Somthing weird i’ve noticed. If you click on ‘About Us’ and then try the drop down menus they work!? If you try it from the home page or ‘Contact Us’ then drop downs don’t work.

Very weird…

i ran an online mixed content checker and it identified this in all the pages :

2023-04-25 19 59 25

would that be a possible cause for the menu to break? If so, any idea where i can change this link in the Concrete files to https if that is the issue?

That script link will be found in your theme header or footer. You should edit them to correct the http to https.
Also, check your application/config/generated_overrides folder for a site.php file and see if the canonical is correctly set to https

I just checked the source code of your website and found this code that indicates an incorrect canonical setting.
CCM_APPLICATION_URL = “http://www.timberventure.co.uk

Thank you very much for checking and for your support, i do appreciate it. Where would i change the CCM_APPLICATION_URL please? at present the canonical boxes are both empty in the Concrete admin settings page

by the way i’m 100% certain that http javascript link is the cause. If i disable the blocked mixed content protection in my browser the menu works!

yep! Just updated the javascript link in the header to https and its now working!

Thank you very much for all your help, i owe you a beer! :smiley:

Your very welcome, I am glad we got there … Pint of Guiness Please

Cheers! Should i need to worry about updating the above now as everything appears to be working? Any idea where i’d find it please?

I just checked the source code of your site and it is now showing as https, so all is good