Missing editor when setting up page type output

So I am trying to setup a new website for our local ham radio organization. A fresh install of concrete 9.2.1 was done within the week. I am trying to setup a page template for calendar events I am missing the edit pencil and the plus sign at the top of the screen to actually edit the template. I have tried in both chrome and firefox. I am logged in as part of the administrators group. Any help would be greatly appreciated on how to get those to show up
php version 7.4.29

Did you check if you didn’t have some CSS interfering with the buttons and hiding them, for instance?

Any javascript interfering?

Can u use php 8, might b better?

What do u c in log error files in the dashboard?

There is not any css or java that I know of interfering. Are you talking about on the server or on the machine I am using to access the website? Other than creating pages from scratch nothing has been changed. I checked my home server running concrete in a container and both functions work there with 7 3 php so that shouldn’t be the problem. The logs under dashboard only shows my page creation and deletion so they are no help. I did just change the log setting to debug and tried to access both. Neither brought up any errors that I see.

Can you post the URL?

Clear cache in the dashboard?

The URL is Home :: Antietam Radio Assn . But the problem on is with page type editing and calendar event attribute tagging so it is not something you will see unless you are logged in

So I am not sure what the problem was. I spun up a new instance and everything is working fine. So no good solution but it is fixed for my purpose

so it happened again and I have no clue what I did. I backed up the other day but can not for the life of me find that backup. So far the problem is only with page types. the calendar seems to functioning fine. I tried to create a new site and copy the data base over to that one and the problem moved so it is an issue in the data base somewhere. I have also tried a second admin account and that did not help out at all

At this point, it’s really not possible to have a clear idea without having a direct look.

If you’d like me to give it a go, feel free to contact me privately to provide me with access to your dashboard and I’ll be happy to help.

that would be great. Cant figure out how to private message on this platform

I just sent you a message. If you click on your avatar in the top right corner, click on the envelop icon in the menu and you’ll see your messages.

To send a message to someone from the forum you can click on their avatar and click on “message”

Alternatively you can visit my profile Profile :: Concrete CMS Community and message me from there

So here’s the solution for the others:
It’s a permission issue.

First you have to enable advanced permissions here:

Once that’s done you go to your page types here:

And you click on the “Permissions” button for the page type you want to modify.

Under “Permissions for All Pages Created Of This Type” (only available once advanced permissions are enabled) You will need to set both “Edit Properties” and “Edit Content” permissions. You might as well set up any other permissions you need.

Then you should be able to edit your page type’s output.

If you logged in as the Admin user to set the permissions and then logged in as a different user to work on the page type, you will still have no access to editing but you’ll see a message in blue telling you it’s because the Admin is already editing the page type. If that happens, make sure you log out of the Admin account first.

I hope this helps.