My package made for 9.1.0+ labeled "Not Version 9 Ready Yet."

My package made for 9.1.0+ labeled “Not Version 9 Ready Yet.”

I think the detector behind this label checks whether only 9.0.0 is supported or not.
Please change it to check whether the recent supported version is greater than 9.0.0 or not.

@hissy I think something funny is going on in general in regards to that package. I saw it was approved. Searching for it, I can not find it. Even searching for “macareux” to see all addons, its not there…

Edit: I don’t see the package stuck in upload testing or anything either.

For your other affected addons I have re-approved, which appears to have resolved the issue. But whether that status remains is …

I have also re-approved this addon, but the incorrect ‘Not v9’ marker remains. Re-approving is as much as I can do.

Please keep an eye on all addons and hassle Franz directly as only he can direct the budget to get these issues resolved.

@JohntheFish Thank you very much!

@frz Please consider fixing this issue, upcoming add-ons may support 9.2.0+.

Hi @hissy - thanks for the heads up, we will take a look into this!

The incorrect v9 compatibility issue continues to happen for newly uploaded/approved addons and themes.

I have to say I never had this problem with my own add-ons, old or new.

I did however also noticed it with a package we were supposed to talk about in our PRB videos. I assumed they simply didn’t click the bottom button to update compatibility so I did but it didn’t fix the problem.

To be fair that button looks useless as all the dropdowns already have the correct value so most people don’t know they’re supposed to click it.

Anyway, what I mean is the problem exists but it is not always happening.

That was my first thought. Doing so had resolved the issue for my addons. But I tried that on addons coming through the PRB (or advised the devs to do so) and in many cases it made no difference.

Unfortunately, the “Update Compatibility” button doesn’t affect the “Version 9 ready” label for me.

@hissy it’s because an assumption was made (perhaps incorrectly) that packages that are v9 compatible would be compatible with versions beginning with 9.0.0. It looks like this package requires >=9.1.0. Does this package really require that version or does it also work with 9.0.0? If the latter, setting the compatibility to 9.0.0 will make it display the correct text.

I’ll pass this on to Andrew though. Clearly in the future (or even now) there will be new addons that require something greater than 9.0.0.

@Myq My package requires 9.1.0 or later. Its interface doesn’t work correctly because of the bug in the external file provider that I fixed.

That’s what I suspected. I made a ticket to improve the logic on that.

1 Like

@hissy We have rolled out that fix and I am seeing your addon marked as version 9 ready and it’s also showing up when the version 9 filter is set for marketplace search. Let me know if that’s all looking good on your end. Thanks!

Thanks, It looks good to me.

1 Like