No entry form in Composer when adding a Blog Post

According to the introductory video, when I create a new Blog Post page, I should get a form in Composer that allows me to create the title and description. The resulting page did not show up in the Blog at all. When I created another test blog post page, the Composer option is automatically selected as expected, but that entire area is blank. Can anyone tell me what is wrong here?

I’m attaching an image from the video showing what I expected to see. Thanks!

When you are creating a new page, is it also a Blog Post page?

If it’s a different page type, it might not be set up with a composer form.
Or, if it is Blog Post, maybe it’s been created as a page type, but not configured beyond that.

To investigate, you would:

  • go to /dashboard/pages/types (Page Types)
  • find the page type and click the Edit Form button

If you do that with just the ‘Page’ page type, you should see a list of fields, like Page Name, Description, etc. But if you do that on your Blog Post page type, and you get no list (perhaps a message like ‘You have not added any composer form layout control sets’), then you don’t have the form set up.

But it’s not too hard to set them up, and the really powerful bit here is that you can set it up however you want, per page type.

Use the ‘Add Set’ button to add field groupings, and then the + sign to add individual fields. You can then customise to your liking, but just keep in mind you’ll need the Page Name, URL Slug and Page Location as a minimum.

I stumbled into manually creating the fields that duplicated what I saw in the video and that seems to have fixed that problem. However, I used the “empty” site option when I created the site and there was no “blog page” set up, only the “blog” type. I had to create that myself.

The only remaining one is that my blog page format specifies the “left sidebar” as the template, but new blog pages consistently ignore that and I have to use their Design interface to set that format manually.

If you return to the Page Types listed in the dashboard, you’ll find that the ‘Basic Details’ button will take you to a page where you can configure the default page template and define which templates are allowed for that page types.

You may just need to revisit this and check those settings, as you defeintely should be able to set it up so that the new page is created with the page template you want.

I was hoping the “templates allowed” setting was wrong, but I’m still getting the wrong template when I added a blog post this morning. I’m attaching the two dashboard screens as they looked before I created the new page. Could there be something else I’m missing? I had to create the Blog Post page type myself.

Okay, after some fermentation, I realized that I did not need to create a “Blog Post” template. I only needed to set the “Allowed Page Templates” to the existing layout that I wanted.

1 Like