Page Not Showing Due to Too Many Redirects

I am having an issue with Concrete5 that I have never seen before. Only one page from a very small site will not show in the browser. Here are the error codes:

In Chrome
This page isn’t redirected you too many times. Try clearing your cookies.

In FireFox
The page isn’t redirecting properly
An error occurred during a connection to problem can sometimes be caused by disabling or refusing to accept cookies.

Page that will not render: Multifamily Investment Opportunities in Houston Texas with Revolution Commercial

This page / site has been built the way I build all my sites and there is no extra URLs or anything different about this page in the CMS. I have turned off pretty URLs and then the page will render. But when I check “remove index.php” from the URL (pretty URLs) then the page will not render. I have also tried with and without the Canonical and Alternate Canonical URL fields. Right now I have both of them set to: I have cleared C5 cache, server cache and browser cache to no avail.

I have probably 25 Concrete5 websites hosted here and no other websites have this issue, nor have I ever seen it before. Could really use some guidance on this one. Thanks.

A bit more information. This website has been launched for about 6 weeks now. It worked just fine until recently. No changes were made to the hosting environment or C5 that I am aware of.

Also, only on this problem page, if you go to Location in the backend and try to put it another URL for this page, you can hit save and C5 says settings saved, but the value is not there if you go back and check… so not saving any additional URLs for this one page.

When I visit that page I get redirected to Multifamily Investment Opportunities in Houston Texas with Revolution Commercial which renders correctly

Yes, sorry I did not update the forum post. I managed a workaround and this is no longer an issue. Thank you.

Hi we have the same problem. What was your workaround?

In my situation, I had a subfolder in my public HTML directory named “contact” and the page name of the page that was giving me trouble was also named “contact”. I am assuming it was causing some kind of conflict. I basically renamed the page to something else and that fixed the issues. Later on I added an additional URL to the page so that it would show even under the old URL. We had some QR codes out in the public so I still needed the /contact/ to work.