Permissions Not Applying To New Pages

I tried setting up a Workflow on my website but couldn’t get it to work with my custom page types because the permissions I set for them are not being inherited.

It seems the permissions are applying to the pages only after they’ve been published. Not when my new writer group goes to create one. Not sure what I’m doing wrong to get the Workflow working correctly as it was shown to be working in this video: Writer/Editor workflow for large teams - YouTube

My new groups are only able to save drafts and the workflow is not coming into play at all even though I have it setup. My writer group has no option to publish like the video above shows, Am I missing an additional step somewhere?

Update 3

Reading more through the documentation I found out you can change the permissions for draft pages which I just copied the permissions I set to the page type here. The workflow is still not being triggered for some reason. When my writer creates a page he only has the option to save a draft and my editor can go to that page and publish it but there is no workflow for approving the page.

I tried to help you, but you chose not to receive messages.
So either change it or… contact me.

Not sure what you’re talking about…

You are blocked from receiving messages on your account - write to me and we’ll talk tomorrow or the day after tomorrow if you want.


I changed it, feel free to message me.

1 Like

@TravsVoid I think you might want to attach it to the add subpage permission?