Please fix Site Error: Saving package documentation page results in 403 error

I’m trying to write documentation for my package, but I can’t save it. When I press the Save button it results in the 403 error.

Please fix the issue. Thank you.

I tried again today - still get the same error. However I noticed that if I just open the page for edit and save it, it saves it. But if I make any change and then save, I get the 403 error.

I tested this on one simple docs page and don’t get this error. However, it was only a simple page I added a couple of words to and my permissions as a PRB Admin will be different to @linuxoid’s.

(I keep most of my documentation on my support site and only maintain simple links to that from the documentation pages at

I then tried editing the docs page @linuxoid has been editing and get the same CloudFront error on save. So this error definitely exists, but does not apply to all documentation pages.

I’ve deleted the page, created a new one, tried to save it - same error

Deleted all text, just typed 3 letters, Save - it saved. Deleted the letters, pasted my text, Save - error

I just tried adding a new docs page to an existing addon. Added, edited, saved x2 then deleted OK. So the issue is not new pages. Someone from Portland needs to examine their Cloudflare logs to see if there is more info available about why you are getting the 403.

Can you clarify which add-on and/or which documentation page you are trying to edit so that I can reproduce the error?

Which “docs page” is that? I’m not sure which page you are referring to.

@Myq , I can’t save this page with long text:

It saves some length of text. But anything longer fails. I’ve just checked again, still get the same error

@Myq , hi.
Is anyone working on the problem? Or do I have to escalate that to Franz?

@linuxoid our devops engineer is looking into it