Problem after running pretty url’s with concrete 9

Since i have started using concrete 9, i have not been able to create pretty url’s. I can run the operation, but afterwards all pages, starting with home give an error and show a 404 page. Then i can’t even use the Dashboard anymore.

So far i have deleted and reeuploaded the site and continued using index.php, but i understand that that is not handy for SEO.

And I believe i also can’t combine the API key with an index.php slug?

Please not I have a multilingual website, so I am not sure if the error is partly due to an incorrect definition/slug of the home page.

If you are looking for technical assistance, be sure and include the version of Concrete and PHP that you are using.

After you check the box in the Dashboard to turn Pretty URLs on they give you some code to put into a .htaccess file, you need to do that manually in many cases.

Manually for every page or the HomePage? I’m the minimum technical user, so i’m always afraid l’ll cause a bigger error.

There’s only one .htaccess file. It’s in the root of your server so ‘public_html’ or ‘htdocs’ … basically wherever the folders that contains the 4 concreteCMS folders.


As hutman says, sometimes concreteCMS can’t modify that file automatically when you turn on Pretty URL’s so you will need to copy 'n paste the lines into the file manually and save the file.

Ok thanks, i understand. But i still have no idea How to do this…

If you would like someone to do this for you, send me an email to