Redirects in v9

Hello team, hope everyone is having a good September. I took the plunge and started building my own site with v9 and Replica theme and it’s going pretty good but I’m stumbling on one thing. I previously used ‘Page Child Redirect’ addon to redirect a parent page to it’s first child. A common practice in my sites. That addon isn’t v9 compatible (or so it says). Any other fairly easy way to accomplish this?

In your dashboard go to “Pages&Themes”, there you see “Attributes”
There you can add a page attribute “Replace Link with First in Nav” which is built in.
Use a checkbox attribute with replace_link_with_first_in_nav, name it ‘Replace Link with First in Nav’ and save. It should appear now in Attributes on your page. Add and activate it. It works on our v9 installations. I hope it works for you.

Awesome! I hoped there was some trick like that. I implemented this and it worked like a charm. Thanks!

@fridayphoto please keep in mind that those two things don’t work the same way.

The page redirect will stop anyone from seeing the page by always redirecting.

the “replace link with first in nav” attribute only works to do just that: replaces the link. Nothing is stopping users from navigating to that page if they have the link. It’s not a redirect.

It’s also only used in Autonav so, for instance, a page list will show the page you’re trying to hide.

I would suggest you have a look at this v9 package: Conditional Redirect - Concrete CMS

Or at this one: Page Redirect - Concrete CMS

The second one is also not marked v9 compatible but it’s free so at least you can try it without spending the money

I believe that most users want their visitors not to land on a parent page with no use exept showing a list of subpages. So, from a users point of view I consider the answer of @blinkdesign somehow correct and useful. Where as @mnakalay delivers a precise answer and technical distinction of the subject. I’m glad I learned that htere’s mor to this problem.

I comment to this thread because I wonder why "replace link with first in nav» is built in and why is it not in available in the selection of page attributes? It its confusing. I, for instance want to skip the parent page and go directly to the my page. Both, also «replace link with first in nav» and «redirect» don’t serve what I want.

How do I get to my desired page directly?

Thanks

Carmel

1 Like

@blinkdesign I have downloaded your template from an earlier post about “inactive parent link” at Autonav - need a item that doesnt act as a page link - #6 by TMDesigns I installed it but won’t work. On an older site, running v.8 it works perfectly.
Now, I’m on v.9.1 with php8.

That is an old template that works in v.7+8, with “Responsive Header Navigation” and won’t work under cms version 9.
PM me, I’ll send you a v.9 template.