Request failed: unable to verify support for request URLs

I’ve installed Concrete on my webserver. But I get an error about the precondition Supports Concrete request URLs. The error message is: Request failed: unable to verify support for request URLs.

It seems to be in the area function getHtml()

$ajaxFailErrorMessage = json_encode(t(‘Request failed: unable to verify support for request URLs’));

$(document).ready(function() {
cache: false,
dataType: ‘json’,
method: ‘GET’,
url: {$url}

.fail(function(xhr, textStatus, errorThrown) {
setWebPreconditionResult({$myIdentifier}, false, {$ajaxFailErrorMessage});

Anyone an idea how I can meet this precondition?

I am trying to run concretecms with PHP v8.0.15.

This often indicates that the php extension ‘curl’ is not enabled on the server.

Just asked my provider, unfortuantely the PHP extension curl is enabled.

Any other ideas?

Yes, ask them to check that php extension mod_rewrite is enabled

just got the answer: Yes, mod_rewrite is enabled.

Hmm, a bit of a long shot but try setting the PHP version at 7.4 to see if this is a PHP version 8 problem.
If the installation completes you could then switch back to PHP 8
ALSO ask if the fileinfo extension is enabled.

Ok, switched to 7.4 and still no luck. I have created a PHP Info File so you can have a quick look at the config of the PHP:

Why is there a concrete-cms-9.0.2 folder in the root of your site?
When you extracted the folders and files into your root you should have moved everything out of the concrete-cms-9.0.2 folder into the root and then deleted that empty concrete-cms-9.0.2 folder.
The folders in the root should be as follows:


and the files should be:


I changed the default root to that path. But hey I really want to give concrete a try, so I have moved everything to the root, deleted all files which is not in your list and I still have the same problem :frowning:

The only thing I can suggest now is that I take a look in your cPanel for you.
If your happy for me to do that send me a private message with the server address, username and password.
Find me in

Hey, I think I just discovered another issue, which could relate to this one. I have modified the requesturl.php to accept the “fault” and I could continue. But on the next site it came up with another error message: is_dir(): open_basedir restriction in effect. File(/var/lib/php/sessions) is not within the allowed path(s): (/var/www/vhosts/

And I fiddled a little bit with my browser and I found this error in the console area of my browser:

If this is the main issue, then maybe there is a way to change the path?

I finally found the solution… I changed 2 settings in my cPanal under the website. From the DOCROOT to WEBSPACEROOT. See the 2 pictures below. Now the error was gone (even after editing the changes in requesturl.php back to normal) and my page is running :slight_smile:

Thanks for the help