Resource temporarily unavailable when writing cache?

Has anyone come across this kind of issue before on a cPanel account?

Screen Shot 2023-06-14 at 11.00.01 pm

One of our clients has flagged this for their own site, on A2 hosting (I believe).
We’ve both tried clearing caches, through the dashboard and manually, and I’ve checked out things like file permissions for the cache folder and files… checked file space, etc… all looks correct and fine, and this error has happened without upgrades or other changes.

The host told my client to do a restore, which I personally don’t think is going to work, as it’s not really a PHP issue, more a filesystem issue. It’s started happening on other sites on the same host as well from what I understand.

Anyone had an experience before with this particular error message?

Does the example .cache file exist? If so, does it seem to have been created with the correct owner and permissions?

Yes, the file existed, but zero bytes.
Correct permissions.
Tried quite a few things. It would re-create itself, but not be able to write to it.

I believe the host has now fixed it, as the sites are running fine, and we didn’t need to action anything. My guess is some more obscure file system issue.