Schedule publishing bug


I have recently used the page scheduled publishing feature and bit confused how it works. First of all FROM and TO option is quite confusing, expectation from seeing this option is that page/content get published between the selected time.
but i got it, it means page/content will publish at FROM and until TO and unpublished before and after.
Now here it gets interesting, I scheduled some contents on my homepage, i expect these contents will publish automatically based on FROM date/time and unpublished TO date/time, but soon as i schedule it, it unpublished my homepage and page shows the 404 error message.

Then FROM date/time page and contents get published, TO date/time only the contents get unpublished.

But unpublished my homepage on scheduling is a bug and that’s shouldn’t be happening.

Let me know if i miss understood this concept?


We are seeing this same issue.

1 Like

Ok, Lets get some info to see if I can find a related bug. What happens when you slide the keep live version approved like in the screenshot?

Are you able to paste your Concrete CMS site’s configuration? Dashboard > System & Settings > Environment > Environment Information

Thank you very much. This setting was actually being overlooked and does not make a lot of sense for pages that have already been published.

Is it possible this setting should only show for newly created pages?

It also does not make sense that the default setting has this setting unchecked especially for already published pages.

For example the setting should state for already published pages “Completely unpublish page? (warning this will cause a 404)”

This setting appears very useful for newly created pages but does not do much for published pages but cause a 404 and confusion for users.

Thanks again

Hi Jes,

Keep live version approved option not available on version 8.
see environment information as requested.

# concrete5 Version
Core Version - 8.5.7
Version Installed - 8.5.7
Database Version - 20210623000000

# Database Information
Version: 5.7.12
SQL Mode: 

# concrete5 Packages
Multi Page Selector Attribute (0.9.1), Speed Analyzer (1.2.5)

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - Off
Full Page Caching - Off
Full Page Cache Lifetime - Every 6 hours (default setting).

# Server Software
Apache/2.4.29 (Ubuntu) mod_fcgid/2.3.9 OpenSSL/1.1.1

# Server API

# PHP Version

# PHP Extensions
apache2handler, calendar, Core, ctype, curl, date, dom, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imagick, intl, json, libxml, mbstring, mysqli, mysqlnd, openssl, pcre, PDO, pdo_mysql, Phar, posix, readline, recode, Reflection, session, shmop, SimpleXML, sockets, sodium, SPL, standard, sysvmsg, sysvsem, sysvshm, tidy, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, Zend OPcache, zip, zlib

# PHP Settings
max_execution_time - 300
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 60
max_input_vars - 1000
memory_limit - 400M
post_max_size - 200M
upload_max_filesize - 100M
mbstring.regex_stack_limit - 100000
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - <i>no value</i>
session.gc_maxlifetime - 7200
opcache.max_accelerated_files - 10000
opcache.max_file_size - 0
opcache.max_wasted_percentage - 5

I can see where some better error messaging will be helpful. Thank you for the additional information. I sent this over to Engineering to look into and decide if we need more testing or should submit some scheduling enhancements into Github.

Thank you Jes,

In the next update can you please add a message that is visible without having to hover anything? This is really important because of the 404 issue. This is actually a serious issue for existing pages. This is causing a lot of confusion and frustration for users. We want them to be happy that we upgraded them to v9, not confused and frustrated.

Also, this setting needs to be enabled by default or something about its functionality needs to change. The fact that scheduling a page change is causing a 404 by default is a problem. If we have the ability to unpublish pages now it should be called just that.

Thank you

I’ve tried to summarize the discussion here in this feature request. If I’ve misunderstood the problem and/or proposed solutions, please add your comments to that issue to help the developers better understand the issue.