Site pages run fine, but Login attempt gives 404

I had a working Concrete site, “” redirected with permanent, Match-www, non-wildcard 301 redirect to “”, that external users can see, and I could log into Concrete from ok. It is an https site. This set up has been working successfully for years.
I upgraded it to 9.2.4 successfully, and ran the security reports, fixing issues before setting the site to Production (and enabling all suggested caching as part of the security reports).

Stupidly, I changed the Pretty URL options to Pretty URL’s. Since then, while the production site works fine for users, when I try to log in to Concrete, I get a 404 error message instead of the login page. The URL shown that fails is “”.

The only way to get the login page to render is to manually type the URL “”. However, on entering userid and password, and pressing enter, the next page that fails is “”.
If I insert index.php again: “”, I am returned to the login screen with the error message: “Invalid form token. Please reload this form and submit again.”

How can I reset the Pretty URL settings to allow me to log in again, without at this time being able to log in to the dashboard?

(Concrete version: 9.2.4, PHP version: 8.1.26)

Make sure the following option is set to true.

'url_rewriting' => true

Thanks for responding - it is:
‘seo’ => [
‘redirect_to_canonical_url’ => true,
‘url_rewriting’ => true,

That was actually the problem - I manually edited to

‘seo’ => [
‘redirect_to_canonical_url’ => true,
‘url_rewriting’ => false,
and the problem was fixed - I could log in and use the dashboard.