Sitemap 'no data' for publish location

I have a brand new v9.3.1 site php8. When trying to add a page it is not to publish the page because set location shows 'no data’in sitemap.

Tried generating a site map but this makes no difference.

I only have one page ‘home’ at this stage.

What am i doing wrong?

Go to the sitemap, click the home page and select ‘Add a Page’ then just follow the prompts.

I have tried this but I cannot set the page location under Home. Home exists as a page and in the nav but does not appear in the sitemap. Sitemap in dashboard says 'no data ’

<urlset xmlns="">

I would check that the DNS (Domain Name Server) settings are setup correctly because you only have an IP address for your domain name?
Are you trying to build on a local machine (PC) or a live server?

Its a local server. dns is working, domain resolves but reverts to ip addr in browser for some reason. I will look into that.

server dns is ok but I had canonical url set as ip address in concrete. I have changed that to the domain and generated a sitemap but the issue still remains. The concrete sitemap still says ‘no data’ and I can’t therefore add pages.

I am stumped :neutral_face:

So after much checking of permissions and everything else I concluded that the install was somehow broken, I don’t know how it happened but since it is not a live site and has no content I decided to reinstall v9.3.1 afresh. I then used @jero Fileset Migration Tool straight into v9.3.1, It needed php7 to prevent errors but the fileset migration worked perfectly and my site is now working properly and the sitemap is showing properly. I also have my filesets and images with descriptions. :grinning:

It does sound like the initial install was somehow interrupted. If you are comfortable using the command line, an easy way to start over is to use ./concrete/bin/concrete c5:reset