[SOLVED] User is not registered. Check your authentication controller

Upgraded server to php 7.4 and concrete5 to v8.5.5.

Getting this error whenever trying to login since the upgrade:
“User is not registered. Check your authentication controller.”

Interestingly, I can copy site and db to local machine, then direct a random url to that machine and the site will allow login without this error. Both machines running identically versions of operating system, linux kernel, mariadb, php, and nginx… Reason I would redirect a URL to a local dev station is so that an SSL certificate gets generated for the dev station too, just to be testing the site under same exact conditions as when on production server.

I’ve tried using different machines within my LAN and get same results. Tried different browsers etc…

Any help is super appreciated.

I don’t know if this will help but that error is displayed when authentication was successful but the session was not attached to an authenticated session for some reason.

So I was able to replicate the error on my dev machine by forwarding a second URL to a different local c5 site and generating an SSL for that domain as well…

Apparently, something is going on with ACME that is causing this error when more than one certificate is loaded onto the server.

So the issue is I was using the same user/group for multiple phpfpm pools. Apparently not suppose to do that. Gave each site its own user/group to run its phpfpm pool and no more login issues.

@ob7dev you should mark your last post as a ‘Solution’ for future reference.

Here is another solution for the same error message. I had also issues with SSL zertificates.
The SSL certificate was active and working for frontend. But the login failed every time.
So I had to correct the cannonical url in:


There was an entry with http:// instead of https:// – so i added the “s” and cleared all caches from my browser and problem solved.