Update 9.1.1 to 9.1.2 fails

Trying to update from 9.1.1 to 9.1.2 I get the following error. Has anyone experienced similar problems??

As I read the requirements, 9.1 requires php 8

9.1 does not require php8. It ‘supports’ php8 and requires php7. Support for php8 is new, so you can expect to run into occasional code issues in little used parts of the core and in addons and themes.

Concrete CMS 9.0 requires PHP 7.3 or greater.

Try using php7.4.

I tried it with php7.4 (see screenshot) and I also tried it with php8: same error. And it doesn’t occur in little used parts, but during update process.

Have you tried a manual update by replacing the /concrete directory and using the command line?

Make a database (and files) backup first.

I prefer to modify the process to upload the new core directory as /concrete921, then rename the old /concrete to /concrete_old, then rename /concrete921 to /concrete.
Then run the CLI update command.
Then once confident the update is complete and healthy, delete /concrete_old.

That way, should an update break the site, I can restore the old code quickly and usually only need to restore the database from backup, not the full site files.