Updating to TLS 1.2 with SMTP method through Office365

I’m getting this message in the log from the form block email function using SMTP to Office365… it’s to do with Microsoft not supporting TLS 1.0 and 1.1 any more, but it seems to have broken the method:

The following error was found while trying to send the test email:
4.7.66 TLS 1.0 and 1.1 are not supported. Please upgrade/update your client to support TLS 1.2. Visit New opt-in endpoint available for SMTP AUTH clients still needing legacy TLS - Microsoft Tech Community. [LO2P123CA0105.GBRP123.PROD.OUTLOOK.COM]

Anyone know how best to fix this? I’m using v8.4.1.

In general, you need to disable older TLS protocols as they are considered insecure and not supported by most clients today. If you are not on a shared hosting service and have privileges, remove TLS 1.0 and 1.1 completely, then enable TLS v2 and v3.

For our Apache configs, we have this:
SSLProtocol all -SSLv2 -SSLv3

More info can be found here:

Disable old TLS versions (1.0/1.1 ) for Apache/Nginx on Ubuntu 18.04 or CentOS 7

Note: there is (was) a typo with regard to the section on Ubuntu - second section says CentOS but should be Ubuntu.

Hi… I’m afraid it’s a shared server so I’m unable to disable older versions, but it’s supposed to be enabled for up to 1.3. Is there way to script Concrete to use 1.2? I’m bit frontend so this isn’t my area of expertise…

That’s a good question. I don’t know if you can force which TLS version to use. The ohter alternative is to ask your host if they can migrate you to a server that does not have TLS 1.0/1.1 installed. Of course, that may come with an IP address change as well.

Okay, thanks for the input J