コンクリートv8.4 ログインできなくなった

V8.4を使ってますが、突然ログインできなくなりました。HPも表示されなくなりました。
https://yufuin-onsen.jp
さくらサーバーを使っております。
どなたか教えてくださいませ。

@namisi66 こんにちは。

どのようにログインできなくなったか、もうちょっと詳細を教えてくれますか?

カッツさん、ご連絡ありがとうございます。
多分、さくらサーバーでPHPバージョン5を使っていて終了したみたいです。
データベースとconcrete5を削除して、とりあえず古いHTMLに変更しました。
新しくconcretecmsV9.3で作り直そうと思います。
知識不足でnodeがうまく使えないので、テーマの最低限必要なファイルをオーバーライドして作ってみます。またうまくいかなかったら教えてくださいませ。ありがとうございました。

@namisi66 こんにちは

さくらサーバーでPHPバージョン5を使っていて終了

あー、なるほど。

Concrete CMS v8.4 であれば、
8.5.12 にアップグレードしていただく必要がありますが
PHP7.4 で使い続けることができたと思います。

V9 で作り直されるのもいいと思います。

またわからないことがあれば、言ってください。

何度もすみません。また教えてください。
atomik-cloneを入れてる途中ですが、 ターミナルでnpm install laravel–mix–save-devを実行したら以下のように出たのですが、どうしたらいいか教えてください。
PowerShell 7.3.1
PS C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build> npm install laravel–mix–save-dev
npm WARN ERESOLVE overriding peer dependency
npm WARN While resolving: @pnotify/bootstrap3@5.2.0
npm WARN Found: bootstrap@4.6.2
npm WARN node_modules/bootstrap
npm WARN peer bootstrap@"^3.1.0 || ^4.4.0" from bootbox@5.5.3
npm WARN node_modules/bootbox
npm WARN bootbox@"^5.5.1" from @concretecms/bedrock@1.3.7
npm WARN node_modules/@concretecms/bedrock
npm WARN 3 more (bootstrap-select, @pnotify/bootstrap4, selectize-bootstrap4-theme)
npm WARN
npm WARN Could not resolve dependency:
npm WARN peer bootstrap@"^3.4.1" from @pnotify/bootstrap3@5.2.0
npm WARN node_modules/pnotify/node_modules/@pnotify/bootstrap3
npm WARN @pnotify/bootstrap3@“5.2.0” from pnotify@5.2.0
npm WARN node_modules/pnotify
npm WARN
npm WARN Conflicting peer dependency: bootstrap@3.4.1
npm WARN node_modules/bootstrap
npm WARN peer bootstrap@"^3.4.1" from @pnotify/bootstrap3@5.2.0
npm WARN node_modules/pnotify/node_modules/@pnotify/bootstrap3
npm WARN @pnotify/bootstrap3@“5.2.0” from pnotify@5.2.0
npm WARN node_modules/pnotify
npm ERR! code E404
npm ERR! 404 Not Found - GET https://registry.npmjs.org/laravel--mix--save-dev - Not found
npm ERR! 404
npm ERR! 404 ‘laravel–mix–save-dev@*’ is not in this registry.
npm ERR! 404
npm ERR! 404 Note that you can also install from a
npm ERR! 404 tarball, folder, http url, or git url.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\imus1\AppData\Local\npm-cache_logs\2023-01-18T22_42_57_684Z-debug-0.log
PS C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build>

@namisi66

コマンドが間違っているようです。

間違い

npm install laravel–mix–save-dev

正解

npm install laravel–mix –-save-dev

laravel-mix と --save-dev の間はスペースがあります。
あと、–save-dev のハイフンが二つです。

これで試してみてください。

返信ありがとうございます。
npm install laravel–mix –-save-devでやってみたのですが、エラーが出るみたいです。
今までの経緯に問題があるかと思って、経緯に問題はないのかお願いします。
そこで最初のnpm installでエラーが出てたので、npm install --save --legacy-peer-depsと入れたらエラーが出なかったので次にnpm init -yを実行して、npm install laravel–mix –-save-devを入れました。

PowerShell 7.3.1
PS C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build> npm install
npm WARN ERESOLVE overriding peer dependency
npm WARN While resolving: @pnotify/bootstrap3@5.2.0
npm WARN Found: bootstrap@4.6.2
npm WARN node_modules/bootstrap
npm WARN peer bootstrap@"^3.1.0 || ^4.4.0" from bootbox@5.5.3
npm WARN node_modules/bootbox
npm WARN bootbox@"^5.5.1" from @concretecms/bedrock@1.3.7
npm WARN node_modules/@concretecms/bedrock
npm WARN 3 more (bootstrap-select, @pnotify/bootstrap4, selectize-bootstrap4-theme)
npm WARN
npm WARN Could not resolve dependency:
npm WARN peer bootstrap@"^3.4.1" from @pnotify/bootstrap3@5.2.0
npm WARN node_modules/pnotify/node_modules/@pnotify/bootstrap3
npm WARN @pnotify/bootstrap3@“5.2.0” from pnotify@5.2.0
npm WARN node_modules/pnotify
npm WARN
npm WARN Conflicting peer dependency: bootstrap@3.4.1
npm WARN node_modules/bootstrap
npm WARN peer bootstrap@"^3.4.1" from @pnotify/bootstrap3@5.2.0
npm WARN node_modules/pnotify/node_modules/@pnotify/bootstrap3
npm WARN @pnotify/bootstrap3@“5.2.0” from pnotify@5.2.0
npm WARN node_modules/pnotify

up to date, audited 1091 packages in 2s

85 packages are looking for funding
run npm fund for details

11 vulnerabilities (5 high, 6 critical)

To address issues that do not require attention, run:
npm audit fix

Some issues need review, and may require choosing
a different dependency.

Run npm audit for details.
PS C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build> npm install --save --legacy-peer-deps

removed 240 packages, and audited 851 packages in 5s

82 packages are looking for funding
run npm fund for details

5 critical severity vulnerabilities

Some issues need review, and may require choosing
a different dependency.

Run npm audit for details.
PS C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build> npm init-y
Unknown command: “init-y”

Did you mean this?
npm init # Create a package.json file

To see a list of supported npm commands, run:
npm help
PS C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build> npm install laravel-mix --save-dev
npm WARN ERESOLVE overriding peer dependency
npm WARN While resolving: @pnotify/bootstrap3@5.2.0
npm WARN Found: bootstrap@4.6.2
npm WARN node_modules/bootstrap
npm WARN peer bootstrap@"^3.1.0 || ^4.4.0" from bootbox@5.5.3
npm WARN node_modules/bootbox
npm WARN bootbox@"^5.5.1" from @concretecms/bedrock@1.3.7
npm WARN node_modules/@concretecms/bedrock
npm WARN 3 more (bootstrap-select, @pnotify/bootstrap4, selectize-bootstrap4-theme)
npm WARN
npm WARN Could not resolve dependency:
npm WARN peer bootstrap@"^3.4.1" from @pnotify/bootstrap3@5.2.0
npm WARN node_modules/pnotify/node_modules/@pnotify/bootstrap3
npm WARN @pnotify/bootstrap3@“5.2.0” from pnotify@5.2.0
npm WARN node_modules/pnotify
npm WARN
npm WARN Conflicting peer dependency: bootstrap@3.4.1
npm WARN node_modules/bootstrap
npm WARN peer bootstrap@"^3.4.1" from @pnotify/bootstrap3@5.2.0
npm WARN node_modules/pnotify/node_modules/@pnotify/bootstrap3
npm WARN @pnotify/bootstrap3@“5.2.0” from pnotify@5.2.0
npm WARN node_modules/pnotify
npm WARN deprecated source-map-url@0.4.1: See GitHub - lydell/source-map-url: [DEPRECATED] Tools for working with sourceMappingURL comments.
npm WARN deprecated urix@0.1.0: Please see GitHub - lydell/urix: [DEPRECATED] Makes Windows-style paths more unix and URI friendly.
npm WARN deprecated source-map-resolve@0.5.3: See GitHub - lydell/source-map-resolve: [DEPRECATED] Resolve the source map and/or sources for a generated file.
npm WARN deprecated chokidar@2.1.8: Chokidar 2 does not receive security updates since 2019. Upgrade to chokidar 3 with 15x fewer dependencies
npm WARN deprecated resolve-url@0.2.1: GitHub - lydell/resolve-url: [DEPRECATED] Like Node.js’ `path.resolve`/`url.resolve` for the browser.

added 240 packages, and audited 1091 packages in 7s

85 packages are looking for funding
run npm fund for details

11 vulnerabilities (5 high, 6 critical)

To address issues that do not require attention, run:
npm audit fix

Some issues need review, and may require choosing
a different dependency.

Run npm audit for details.
PS C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build>

どうしたらいいのかわかりません。教えてくださいませ。

@namisi66 チュートリアルを作ってから状況が変わったかもですね。
ちょっと見てみます

返信しようとすると、「本文が不明瞭なようですが、完全な文ですか?」って出て返信できないのはなぜですか?

1 Like

いけそうですね?
返信ありがとうございます。
npmとかlaravel-mixとかの件で、エラーっぽいのがWARNとかエラーみたいなのがいっぱい出てきて、さっぱりわからないです。このまま進めていいものか、ご教授お願いします。

@namisi66 すいません。まだ僕の環境でテストできる時間がないのですが、結果を見る限り、WARN (警告) だけのようです。ERROR (エラー) が表示されていない限り動く可能性があるので、このまま進めてもらってもいいと思います。

ありがとうございます。何度もすみません。
その後、エラーが出ましたので、ご教授願います。
以下の通りです。
その後、エラーではないので無視して、再度
$ npm install
$ npm init -y
$ npm install laravel‒mix ‒-save-dev
$ npm install @concretecms/bedrock
をやってみました。
その後、
npm run prod
を実行してみましたが、以下のようなエラーが出ました。
どうしたらよろしいでしょうか?
PowerShell 7.3.2
PS C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build> npm install
npm WARN ERESOLVE overriding peer dependency
npm WARN While resolving: @pnotify/bootstrap3@5.2.0
npm WARN Found: bootstrap@4.6.2
npm WARN node_modules/bootstrap
npm WARN peer bootstrap@"^3.1.0 || ^4.4.0" from bootbox@5.5.3
npm WARN node_modules/bootbox
npm WARN bootbox@"^5.5.1" from @concretecms/bedrock@1.3.7
npm WARN node_modules/@concretecms/bedrock
npm WARN 3 more (bootstrap-select, @pnotify/bootstrap4, selectize-bootstrap4-theme)
npm WARN
npm WARN Could not resolve dependency:
npm WARN peer bootstrap@"^3.4.1" from @pnotify/bootstrap3@5.2.0
npm WARN node_modules/pnotify/node_modules/@pnotify/bootstrap3
npm WARN @pnotify/bootstrap3@“5.2.0” from pnotify@5.2.0
npm WARN node_modules/pnotify
npm WARN
npm WARN Conflicting peer dependency: bootstrap@3.4.1
npm WARN node_modules/bootstrap
npm WARN peer bootstrap@"^3.4.1" from @pnotify/bootstrap3@5.2.0
npm WARN node_modules/pnotify/node_modules/@pnotify/bootstrap3
npm WARN @pnotify/bootstrap3@“5.2.0” from pnotify@5.2.0
npm WARN node_modules/pnotify

up to date, audited 1091 packages in 9s

85 packages are looking for funding
run npm fund for details

11 vulnerabilities (5 moderate, 5 high, 1 critical)

To address issues that do not require attention, run:
npm audit fix

Some issues need review, and may require choosing
a different dependency.

Run npm audit for details.
npm notice
npm notice New major version of npm available! 8.19.3 → 9.4.1
npm notice Changelog: Release v9.4.1 · npm/cli · GitHub
npm notice Run npm install -g npm@9.4.1 to update!
npm notice
PS C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build> npm init-y
Unknown command: “init-y”

Did you mean this?
npm init # Create a package.json file

To see a list of supported npm commands, run:
npm help
PS C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build> npm install laravel-mix --save-dev
npm WARN ERESOLVE overriding peer dependency
npm WARN While resolving: @pnotify/bootstrap3@5.2.0
npm WARN Found: bootstrap@4.6.2
npm WARN node_modules/bootstrap
npm WARN peer bootstrap@"^3.1.0 || ^4.4.0" from bootbox@5.5.3
npm WARN node_modules/bootbox
npm WARN bootbox@"^5.5.1" from @concretecms/bedrock@1.3.7
npm WARN node_modules/@concretecms/bedrock
npm WARN 3 more (bootstrap-select, @pnotify/bootstrap4, selectize-bootstrap4-theme)
npm WARN
npm WARN Could not resolve dependency:
npm WARN peer bootstrap@"^3.4.1" from @pnotify/bootstrap3@5.2.0
npm WARN node_modules/pnotify/node_modules/@pnotify/bootstrap3
npm WARN @pnotify/bootstrap3@“5.2.0” from pnotify@5.2.0
npm WARN node_modules/pnotify
npm WARN
npm WARN Conflicting peer dependency: bootstrap@3.4.1
npm WARN node_modules/bootstrap
npm WARN peer bootstrap@"^3.4.1" from @pnotify/bootstrap3@5.2.0
npm WARN node_modules/pnotify/node_modules/@pnotify/bootstrap3
npm WARN @pnotify/bootstrap3@“5.2.0” from pnotify@5.2.0
npm WARN node_modules/pnotify

up to date, audited 1091 packages in 3s

85 packages are looking for funding
run npm fund for details

11 vulnerabilities (5 moderate, 5 high, 1 critical)

To address issues that do not require attention, run:
npm audit fix

Some issues need review, and may require choosing
a different dependency.

Run npm audit for details.
PS C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build> npm install @concretecms/bedrock
npm WARN ERESOLVE overriding peer dependency
npm WARN While resolving: @pnotify/bootstrap3@5.2.0
npm WARN Found: bootstrap@4.6.2
npm WARN node_modules/bootstrap
npm WARN peer bootstrap@"^3.1.0 || ^4.4.0" from bootbox@5.5.3
npm WARN node_modules/bootbox
npm WARN bootbox@"^5.5.1" from @concretecms/bedrock@1.3.7
npm WARN node_modules/@concretecms/bedrock
npm WARN 3 more (bootstrap-select, @pnotify/bootstrap4, selectize-bootstrap4-theme)
npm WARN
npm WARN Could not resolve dependency:
npm WARN peer bootstrap@"^3.4.1" from @pnotify/bootstrap3@5.2.0
npm WARN node_modules/pnotify/node_modules/@pnotify/bootstrap3
npm WARN @pnotify/bootstrap3@“5.2.0” from pnotify@5.2.0
npm WARN node_modules/pnotify
npm WARN
npm WARN Conflicting peer dependency: bootstrap@3.4.1
npm WARN node_modules/bootstrap
npm WARN peer bootstrap@"^3.4.1" from @pnotify/bootstrap3@5.2.0
npm WARN node_modules/pnotify/node_modules/@pnotify/bootstrap3
npm WARN @pnotify/bootstrap3@“5.2.0” from pnotify@5.2.0
npm WARN node_modules/pnotify

up to date, audited 1091 packages in 2s

85 packages are looking for funding
run npm fund for details

11 vulnerabilities (5 moderate, 5 high, 1 critical)

To address issues that do not require attention, run:
npm audit fix

Some issues need review, and may require choosing
a different dependency.

Run npm audit for details.
PS C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build> npm run prod

atomik-clone@1.0.0 prod
mix --production

:heavy_multiplication_x: Mix
Compiled with some errors in 5.70s

ERROR in ./assets/scss/presets/default/main.scss
Module build failed (from ./node_modules/mini-css-extract-plugin/dist/loader.js):
ModuleBuildError: Module build failed (from ./node_modules/sass-loader/dist/cjs.js):
SassError: (“primary”: #2D7AC0, “secondary”: #676D6F, “success”: #04AF7A, “info”: #20BFF0, “warning”: #F0B720, “danger”: #A32C0D, “light”: #F3F3F3, “dark”: #373A3B, “light-accent”: #9BA5B0, “accent”: #F14A20, “dark-accent”: #014357) isn’t a valid CSS value.

88 │ $theme-colors-rgb: map-loop($theme-colors, to-rgb, “$value”);
│ ^^^^^^^^^^^^^

assets\scss_shared-variables.scss 88:29 @import
assets\scss_common.scss 1:9 @import
assets\scss\presets\default\main.scss 3:9 root stylesheet
at processResult (C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build\node_modules\webpack\lib\NormalModule.js:758:19)
at C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build\node_modules\webpack\lib\NormalModule.js:860:5
at C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build\node_modules\loader-runner\lib\LoaderRunner.js:400:11
at C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build\node_modules\loader-runner\lib\LoaderRunner.js:252:18
at context.callback (C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build\node_modules\loader-runner\lib\LoaderRunner.js:124:13)
at Object.loader (C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build\node_modules\sass-loader\dist\index.js:69:5)

ERROR in ./assets/scss/presets/rustic-elegance/main.scss
Module build failed (from ./node_modules/mini-css-extract-plugin/dist/loader.js):
ModuleBuildError: Module build failed (from ./node_modules/sass-loader/dist/cjs.js):
SassError: (“primary”: #75CFB8, “secondary”: #676D6F, “success”: #04AF7A, “info”: #20BFF0, “warning”: #F0B720, “danger”: #A32C0D, “light”: #F0E5D8, “dark”: #373A3B, “light-accent”: #F0E5D8, “accent”: #75CFB8, “dark-accent”: #014357) isn’t a valid CSS value.

88 │ $theme-colors-rgb: map-loop($theme-colors, to-rgb, “$value”);
│ ^^^^^^^^^^^^^

assets\scss_shared-variables.scss 88:29 @import
assets\scss_common.scss 1:9 @import
assets\scss\presets\rustic-elegance\main.scss 3:9 root stylesheet
at processResult (C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build\node_modules\webpack\lib\NormalModule.js:758:19)
at C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build\node_modules\webpack\lib\NormalModule.js:860:5
at C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build\node_modules\loader-runner\lib\LoaderRunner.js:400:11
at C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build\node_modules\loader-runner\lib\LoaderRunner.js:252:18
at context.callback (C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build\node_modules\loader-runner\lib\LoaderRunner.js:124:13)
at Object.loader (C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build\node_modules\sass-loader\dist\index.js:69:5)

2 ERRORS in child compilations (Use ‘stats.children: true’ resp. ‘–stats-children’ for more details)
webpack compiled with 4 errors
PS C:\Users\imus1\Desktop\cc66c\packages\atomik_theme_clone\build>