V9.0.1: Permissions issue for non-admin group/user


I just got my first taste of Concrete and liked it a lot. However, there is one nagging issue when trying to enable File Manager for non-admin users by following these instructions:


I created a new (test) user and attached it to a non-admin group. After giving the group permissions to use Dashboard, the user was able to see it without issues.

But when I opened File Manager, I got this:


I got exactly same error also for the Sitemap.

In both cases I gave the non-admin group all possible (advanced) permissions for both applications, so this should not be the case of selecting wrong ones. I also tried to attach user to administrators-group (which has permissions to use both apps) and user was immediately able to access the apps.

Has anybody else experienced anything similar with v9.x? I have not tried and do no plan to try older versions.

Well, I got it working after all. The problem was the lack of Task Permissions and File Manager Permissions for the group; I had looked under both settings but as they were empty, I just bypassed them.

However, I didn’t realize that my own personal user was lacking necessary permissions for those settings even though it was under Administrators-group. But after switching to actual admin user, I was finally able to see permissions under those settings.