Getting error when installing version 9 on local computer

Getting this error when installing new version 9 on Windows 10 in XAMPP server.

Fatal error: Maximum execution time of 1000 seconds exceeded in Z:\JNBD\Project\public\concrete-cms-9.0.1\concrete\vendor\doctrine\dbal\lib\Doctrine\DBAL\Driver\PDOStatement.php on line 55
{“error”:{“type”:“Whoops\Exception\ErrorException”,“message”:“Maximum execution time of 1000 seconds exceeded”,“code”:1,“file”:“Z:\JNBD\Project\public\concrete-cms-9.0.1\concrete\vendor\doctrine\dbal\lib\Doctrine\DBAL\Driver\PDOStatement.php”,“line”:55,“trace”:[{“file”:“Z:\JNBD\Project\public\concrete-cms-9.0.1\concrete\vendor\doctrine\dbal\lib\Doctrine\DBAL\Driver\PDOStatement.php”,“line”:55,“function”:null,“class”:“Whoops\Exception\ErrorException”,“args”:[“Maximum execution time of 1000 seconds exceeded”]},{“file”:“Z:\JNBD\Project\public\concrete-cms-9.0.1\concrete\vendor\filp\whoops\src\Whoops\Run.php”,“line”:486,“function”:“handleError”,“class”:“Whoops\Run”,“args”:[1,“Maximum execution time of 1000 seconds exceeded”,“Z:\JNBD\Project\public\concrete-cms-9.0.1\concrete\vendor\doctrine\dbal\lib\Doctrine\DBAL\Driver\PDOStatement.php”,55]},{“file”:"[internal]",“line”:0,“function”:“handleShutdown”,“class”:“Whoops\Run”,“args”:[]}]},“errors”:[“Maximum execution time of 1000 seconds exceeded”]}

See Install problem - ini_set(): Tried to raise runtime to 0s beyond limit of 310s - #2 by JohntheFish

The solution options are the same.

I tried all of these solutions and nothing works. I keep getting the same error message. And yes, I made sure I emptied the database before trying each time. Any other suggestions?

Your errors remind me of a similar problem I used to have some years ago, trying to install concrete5 onto my WAMP server I would regularly get php timeouts and I tried every conceivable configuration setting to no avail, finally I realised the problem was the hard disk read/write speed was too low and as soon as I installed an SSD disk all php timeouts just melted away.

That is probably what is happening here although I had previously installed 8.5 on the same drive without problems. I will try 9 on another drive.

Installing from the CLI is exempt from any server timeouts.

Tried installing on local drive on computer instead of NAS drive and still got the timeout error.
I will try to install with the CLI now.

Just tried the CLI install using composer. Got the same error message. Seems the CLI is not exempt from timeouts.

Perhaps it is a XAMPP problem, I use WAMP64 on my windows 11 machine with no problems when installing Version 9.0.1.
You would have to edit the MySQL my.ini file to add lower_case_table_names = 2 beneath the [mysqld] section and restart the server before installing any concrete version.

Yeah, I had already done that. I have installed numerous concrete5 sites before on my local machine using XAMPP and have never had this problem before.

Have you tried a straight CLI install (ie, not a composer install) ?

Somewhere in the XAMPP php configuration will be max_execution_time=1000 (or if not, perhaps it defaults to that). You can either find that value and adjust it, or find where it needs to be and add it with a bigger/unlimited value.

From your screenshot it looks like php is falling over at creating database tables so… when the installation fails are any tables created in the database?
Are you setting the database collation to utf8mb4_unicode_ci

1 Like

@JohntheFish. I did that before I tried the install. The CLI install using composer is the only CLI install I seen in the documentation. If you have a link to just a CLI install, please share.

About 20% down the long page

It creates about 250 tables before the fail. The database collation defaults to utf8mb4_unicode_ci. Does it need to be something else?
I never had to change it for other versions of concrete.

Thx JohnTheFish, I will try this tonight.

No need to change that collation, it is correct.
250 tables is the point at which pagination is created by MySQL, there are usually two pages of tables.

@JohnTheFish tried the CLI install just using the c5:install command and still get the same error message. Always hangs at Creating database tables and then after a few minutes times out. I have set the max_execution_time in my php.ini file to like 1000000. It even says that if you set it to 0 it is unlimited and it defaults to 0 in the CLI anyway. I don’t know what is going on. I guess I won’t be using concrete cms any longer.

I was able to install concreteCMS 9 on my iMac that is running MAMP PRO.
Cannot install on Windows 10 with XAMPP.

If you have effectively no time limit and it still hangs, that suggests time is not the real issue here.

Have you kept record of which was the last table created? Is it always the same table? What version of MySQL is installed?

As an alternative to directly installing, you can get round the installer by installing an empty site on another system then cloning the site onto your PC. With a successful install on your iMac you have a source for such a site.

Ignore the bit about directories and just copy the whole lot. You end up with a bigger than necessary zip, but that is usually easier than filling in the gaps later.

Export the database from your iMac. Zip up the directory with the v9 site in it.

Unzip the dir on your PC. Then, bearing in mind your timeout issues, you would likely want to import the database using the command line rather than via phpMyAdmin. Then edit /application/config/database.php

The whole process is usually easiest if you switch off the cache and put database entities into development mode on the source before copying.